www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steinar Fremme <stei...@fremme.no>
Subject general/373: Timeout problems
Date Sun, 13 Apr 1997 18:50:01 GMT

>Number:         373
>Category:       general
>Synopsis:       Timeout problems
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sun Apr 13 11:50:01 1997
>Originator:     steinar@fremme.no
>Organization:
apache
>Release:        1.2b8
>Environment:

I'm using perl, version 5.003_93
          apache        1.2b8
          gcc           2.7.2
          linux         2.0.27
>Description:
I upgraded to new version of apache from
1.2b6 to 1.2b8 on my Linux 2.0.27 system.

This morning the server was out of memory, and I
found a lot of unterminated requests.

>From apache status info there was a lot of servers
in "mode of operation = W".

I restarted the servers, and all memory was released
servers started and all was looking god.

Then I started a Perl CGI from my browser making some
200Kb output, and was pressing STOP from the browser.

The "apache status info" was again showing me that the
server was in  "mode of operation = W" - But then after
10 minutes - the server was still there in same mod., and
the Perl CGI still loaded.

My httpd.conf have Timeout set to 120.

Is it not so that this timeout supposed to kill the server
after 120 sec in my case ??

I did not have this problem in 1.2b6
>How-To-Repeat:
http://www.fremme.no/st1100/stoc.cgi?sort=nr&ss=999
http://www.fremme.no/status
>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message