www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill <Petersen>
Subject mod_include/310: file=/name does not seem to work file=name works fine
Date Thu, 03 Apr 1997 17:50:01 GMT

>Number:         310
>Category:       mod_include
>Synopsis:       file=/name does not seem to work  file=name works fine
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Apr  3 09:50:01 1997
>Originator:     Petersen
>Organization:
apache
>Release:        1.2b6
>Environment:
Solaris 2.5.1
>Description:
<!--#include file="footnote.shtml" -->
resolves just fine, but
<!--#include file="/footnote.shtml" -->
does not seem to resolve correctly, or at least I have 
tried all of the places I think it would resolve to, and have
not gotten it to work yet.  I tried DOCHOME, /, relative home
for instance if I am in http://somemachine.com/~bill
should it resolve to /, to /usr/local/etc/httpd/,
/usr/local/etc/httpd/htdocs, to ~bill/
I have not gotten any of these to work.
>How-To-Repeat:
No, it is on an internal, firewalled site
>Fix:
no.  I guess since HREF=/footnote.html as a link resolves to
/usr/local/etc/httpd/htdocs/footnote.html, I would have thought
that a SSI include of file=/footnote.html should do the same
>Audit-Trail:
>Unformatted:



Mime
View raw message