www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@kiwi.ICS.UCI.EDU>
Subject Re: general/232: Apache 1.2b7/b8-dev causes Netscape to display some jpeg's as broken images
Date Sat, 15 Mar 1997 17:15:38 GMT

I confirmed the problem using Netscape 3.01/X-Windows.  Using my libwww-perl
client, the response message from the source server is

   HTTP/1.1 200 OK
   Date: Sat, 15 Mar 1997 16:36:25 GMT
   Server: Apache/1.2b8-dev mod_perl/0.94
   Connection: close
   Content-Type: image/jpeg
   Last-Modified: Fri, 07 Mar 1997 19:25:31 GMT
   ETag: "9be54-fe8-33206bab"
   Content-Length: 4072
   Accept-Ranges: bytes

which appears to be fine.  Unfortunately, I need to see the actual data
sent and received by Netscape in order to guess the problem, and I can't
do that on my machine at the moment.  If you (or anyone) could provide
a network dump/trace, I'd appreciate it.

The same image works fine with Netscape when retrieved from my
Apache/1.2b8-dev test server:

   HTTP/1.1 200 OK
   Date: Sat, 15 Mar 1997 17:10:05 GMT
   Server: Apache/1.2b8-dev
   Connection: close
   Content-Type: image/jpeg
   Last-Modified: Sat, 15 Mar 1997 16:37:40 GMT
   ETag: "7e938-fe8-332ad054"
   Content-Length: 4072
   Accept-Ranges: bytes

and on Apache/1.1.3.  Note that the only significant difference between
the two responses is the presence of mod_perl/0.94, which may be a clue.

....Roy


Mime
View raw message