www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorgen Skjaanes <jor...@pimp.origo.no>
Subject general/228: Ouch! malloc failed in malloc_block()
Date Tue, 11 Mar 1997 13:50:01 GMT

>Number:         228
>Category:       general
>Synopsis:       Ouch!  malloc failed in malloc_block()
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Mar 11 05:50:00 1997
>Originator:     jorgen@pimp.origo.no
>Organization:
apache
>Release:        1.2b7
>Environment:
Linux 2.0.28 from Red Hat 4.0
gcc version 2.7.2
>Description:
Pressing the Submit button causes an "Ouch!  malloc failed in malloc_block()"
to st.error. (Se file and cgi-script below).  
If I remove the NAME atribute, everything is ok.

<HTML>
<FORM METHOD="POST" ACTION="/cgi-bin/somescript">
<INPUT TYPE="submit" NAME="something" VALUE="Submit">
</FORM>

#!/usr/bin/perl
# somescript
print "Content-type: text/html\n\n";
print "<html>";
print "<h3> Whatever..</h3>\n";
>How-To-Repeat:
http://pimp.origo.no/gsi/testindex.html
(or test the short example above).
>Fix:
I _think_ this may not be an Apache bug, but why, then, do I get the Ouch!?
If it _is_ an Apache bug I guess it's rather serious....

Pardon me if this is clearly not a server bug, but since it's a beta
and all that, I thought I'd send it in anyway.

Thanks for any replay!%2
>Audit-Trail:
>Unformatted:



Mime
View raw message