www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Frederic Clere <jfcl...@apache.org>
Subject [SECURITY] CVE-2018-8019 Apache Tomcat Native Connector - Mishandled OCSP invalid response
Date Sat, 21 Jul 2018 09:59:44 GMT
CVE-2018-8019 Apache Tomcat Native Connector - Mishandled OCSP invalid response

Severity: Moderate

Vendor: The Apache Software Foundation

Versions Affected:
Apache Tomcat Native 1.2.0 to 1.2.16
Apache Tomcat Native 1.1.23 to 1.1.34

Description:
When using an OCSP responder Tomcat Native did not correctly handle invalid responses. This
allowed for revoked client certificates to be incorrectly identified. It was therefore possible
for users to authenticate with revoked certificates when using mutual TLS.
Users not using OCSP checks are not affected by this vulnerability.

Mitigation:
Users of the affected versions should apply one of the following
mitigations:
- Upgrade to Apache Tomcat 1.2.17 or later
  Note: This version was included in Apache Tomcat 9.0.10 onwards, 8.5.32
        onwards, 8.0.53 onwards and 7.0.90 onwards.

History:
2018-03-09 Original advisory

References:
[1] http://tomcat.apache.org/security-native.html

Mime
View raw message