Hot on the heels of Commons IO 2.2, the Commons IO team is pleased to announce the Commons IO 2.3 release!

Commons IO is a package of Java utility classes like java.io
Classes in this package are considered to be so standard and of such high
reuse as to justify existence in java.io.

The Commons IO library contains utility classes, stream implementations, file filters,
file comparators, endian transformation classes, and much more.

Changes in this version include:

New features:
o IO-318:  Add Charset sister APIs to method that take a String charset name. Thanks to ggregory.
o IO-321:  ByteOrderMark UTF_32LE is incorrect. Thanks to ggregory.
o IO-322:  Add and use class Charsets. Thanks to ggregory.

Compatibility with 2.2 and 1.4:
Binary compatible: Yes.
Source compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.
Semantic compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.

Commons IO 2.3 requires JDK 1.6 or later.
Commons IO 2.2 requires JDK 1.5 or later.
Commons IO 1.4 requires JDK 1.3 or later.


--
E-Mail: garydgregory@gmail.com | ggregory@apache.org
JUnit in Action, 2nd Ed: http://bit.ly/ECvg0
Spring Batch in Action: http://bit.ly/bqpbCK
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory