www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nandana Mihindukulasooriya <nand...@apache.org>
Subject [ANN] Apache Rampart 1.5 Released
Date Tue, 02 Feb 2010 17:06:56 GMT
Apache Rampart team is pleased to announce the 1.5 release of Apache Rampart
module.

Apache Rampart is the the security module of Axis2 which provides
implementations of the WS-Sec* specifications for Apache Axis2.  Apache
Rampart 1.5 release is compatible with Axis2 1.5 / 1.5.1 releases. Please
refer to http://ws.apache.org/rampart/ for more information.

You can download the release from:
http://ws.apache.org/rampart/download/1.5/download.cgi

Apache Rampart supports the following specifications:
* WS - Security 1.0 / 1.1
* WS - Security Policy - 1.1 / 1.2
* WS - Secure Conversation - February 2005 / WS-SX
* WS - Trust - February 2005 / WS-SX
* SAML 1.1 / 2.0

Apache Rampart 1.5 can be successfully used with the next Apache Sandesha2
release targeted towards Apache Axis2 1.5 to configure WS-SecureConversation
+ WS-ReliableMessaging scenarios.

New features of Apache Rampart 1.5 includes
* SAML 2.0 support
* Key store caching
* Signing / Encrypting with multiple keys
* Tests for negative scenarios

We welcome any and all feedback at:
Issue Tracker : http://issues.apache.org/jira/browse/Rampart
Mailing List     : rampart-dev@ws.apache.org

Thank you for your interest in Apache Rampart!

The Rampart Development Team
http://ws.apache.org/rampart/

Mime
View raw message