www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruchith Fernando <ruchi...@apache.org>
Subject Apache Rampart 1.1 Released
Date Mon, 11 Dec 2006 05:53:45 GMT
Apache Rampart team is happy to announce the 1.1 release of Apache Rampart

You can download the releases from:

http://www.apache.org/dyn/closer.cgi/ws/rampart/1_1

Apache Rampart 1.1 is a toolkit that provides implementations of the
WS-Sec* specifications for Apache Axis 1.1, based on Apache WSS4J 1.5.1
and the Apache AXIOM-DOOM 1.2.1 implementation.
What is in this release

There are two main Apache Axis2 modules provided with this release.

    * rampart-1.1.mar
    * This provides support for WS-Security and WS-SecureConversation
features. rahas-1.1.mar
      This module provides the necessary components to enable
SecurityTokenService functionality on a service.

Apache Rampart 1.1 introduces a new configuration model based on
WS-Policy and WS-Security Policy and it is important to note that Apache
Rampart 1.0 style configuration is now deprecated and will not be
available in next major version.

Apache Rampart 1.1 can be successfully used with the next Apache
Sandesha2 release targeted towards Apache Axis2 1.1 to configure
WS-SecureConversation + WS-ReliableMessaging scenarios.

The rampart module was successfully tested for interoperability with
other WS-Security implementations.

WS - Sec* specifications supported by Apache Rampart are as follows:

    * WS - Security 1.0
    * WS - Secure Conversation - February 2005
    * WS - Security Policy - 1.1 - July 2005
    * WS - Trust - February 2005
    * WS - Trust - WS-SX spec - EXPERIMENTAL

Thank you for using Apache Rampart.

The Apache Rampart team

Mime
View raw message