ws-wss4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Badorrek" <mbador...@avoga.com.au>
Subject Axis2 Rampart.mar FuncLoader' problems
Date Tue, 03 Apr 2007 04:25:52 GMT
Dear all,
 
I'me having a small problem with axis2/rampart that I hope you can help with:
 
Environment:
JDK 1.5
Tomcat 5.0.28
Axis2 1.1.1
Rampart 1.1
 
I've deployed the standard Axis2 WAR to tomcat.
I've dropped the file 'rampart-1.1.mar' into the 'axis2/WEB-INF/modules' directory.
 
*Since this is an out-of-the-box intall, xalan-2.7.0.jar is in the 'axis2/WEB-INF/lib' dir
 
Tomcat boots with the following problem:
 
SEVERE: Invalid module : rampart-1.1.mar caused org/apache/xpath/compiler/FuncLoader
java.lang.NoClassDefFoundError: org/apache/xpath/compiler/FuncLoader
        at org.apache.ws.security.WSSConfig.<init>(WSSConfig.java:72)
        at org.apache.ws.security.WSSConfig.getNewInstance(WSSConfig.java:95)
        at org.apache.ws.security.WSSConfig.<clinit>(WSSConfig.java:47)
        at org.apache.ws.security.WSSecurityEngine.<clinit>(WSSecurityEngine.java:51)
        at org.apache.ws.security.handler.WSHandler.<clinit>(WSHandler.java:62)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
.
.
.
.
 
 
I've noted other threads http://marc.info/?l=wss4j-dev&m=114720403203239&w=2#1 that
explain that if you use the latest copy of Rampart, you will be using version 1.3 of xmlsec.jar
and all will be well.
 
Unfortunately it's not. xmlsec.jar version 1.3 is indeed in my rampart-1.1.mar file and I'm
still enjoying this issue.
 
Can anyone advise?
 
Cheers,
 
Mark B
 

Mime
View raw message