ws-wsif-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksander Slominski <as...@cs.indiana.edu>
Subject Re: Unable to find an available port in TOMCAT
Date Sat, 12 Feb 2005 03:12:55 GMT
Lucy Rong & Qin Wu wrote:

> Hi, Gurus,
>  
> Please help on this issue.
>  
> I could run WSIF dynamic invocation as stand alone, but fails in Tomcat.
> I did get WSIF0006W and WSIF0007I warning message when standalone 
> invocation is used.
>  
> the error in Tomcat is:
> org.apache.wsif.WSIFException: Unable to find an available port
> org.apache.wsif.base.WSIFServiceImpl.getPort(Unknown Source)
> org.apache.wsif.base.WSIFServiceImpl.getPort(Unknown Source)
> prof.DI.invokeMethod(DI.java:166)
> Could anyone tell me what should I do to resolve this problem?
> Is this caused by WSIF0006W? if yes, how should fix it?
> I have found there are two providers:
> 'org.apache.wsif.providers.soap.apacheaxis.WSIFDynamicProvider_ApacheAxis, 
>
> org.apache.wsif.providers.soap.apachesoap.WSIFDynamicProvider_ApacheSOAP',  
>
> how can I remove one?
>  
>  
> One aticle mentioned 
> "META-INF/services/org.apache.wsif.spi.WSIFProvider file that's inside 
> the jar when WSIF asked for it. I extracted that file and placed it 
> into my webapp's classes directory (under META-INF/services, of 
> course) and now it works. " 
> http://www-106.ibm.com/developerworks/forums/dw_expandTree.jsp?thread=63061&forum=166&cat=7&message=4352829#4352829

> <http://www-106.ibm.com/developerworks/forums/dw_expandTree.jsp?thread=63061&forum=166&cat=7&message=4352829#4352829>

> But this hint is too vague to me, could anyone give some help? Where 
> is the webapp's classes directory? I have tried it on 
> jakarta-tomcat-5.0.28/common/classes and 
> jakarta-tomcat-5.0.28/wabapps/myProject/WEB-INF/classes, both are not 
> the solution.
>  
> Please help, Thanks
>  
>  

hi Qin,

try running code with current version of WSIF (2.0.1) it has better 
error messages.
(nightly build is at http://cvs.apache.org/dist/wsif-2.0/nightly/)

in any case your problems looks like classloader realted and those are 
not easy to debug - try moving wsif.jar around and see what happens - is 
wsif.jar in WEB-INF?

HTH,

alek

-- 
The best way to predict the future is to invent it - Alan Kay


Mime
View raw message