ws-woden-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: XMLSchema
Date Tue, 25 Oct 2005 17:09:43 GMT
Fixed all 3 problems. Please get latest SVN for XmlSchema.

thanks,
dims

On 10/20/05, John Kaputin <KAPUTIN@uk.ibm.com> wrote:
> Dims,
>
> PROBLEM 1
> test case -  http://www.uddi.org/schema/uddi_v2.xsd
> org.apache.ws.commons.schema.XmlSchemaException: No namespace found in
> given base simple content type
>       at
> org.apache.ws.commons.schema.SchemaBuilder.handleSimpleContentExtension(SchemaBuilder.java:759)
>
> patch1.txt seems to fix problem 1.
> (See attached file: patch1.txt)
>
> PROBLEM 2
> occurred with the same test case after applying patch1.  The handleElement
> method is passing a null value for the localPart to the QName ctor.
> test case -  http://www.uddi.org/schema/uddi_v2.xsd
> java.lang.IllegalArgumentException: localpart cannot be null.
>       at javax.xml.namespace.QName.<init>(QName.java:130)
>       at javax.xml.namespace.QName.<init>(QName.java:102)
>       at
> org.apache.ws.commons.schema.SchemaBuilder.handleElement(SchemaBuilder.java:1405)
>
> PROBLEM 3
> Seems it cannot handle relative filepaths for the schemaLocation on a
> schema import.
> org.apache.ws.commons.schema.XmlSchemaException: no protocol: name.xsd
>       at
> org.apache.ws.commons.schema.SchemaBuilder.getXmlSchemaFromLocation(SchemaBuilder.java:1835)
>       at
> org.apache.ws.commons.schema.SchemaBuilder.handleImport(SchemaBuilder.java:1653)
>       at
> org.apache.ws.commons.schema.SchemaBuilder.handleXmlSchemaElement(SchemaBuilder.java:113)
> two test files are test3.xsd and name.xsd.
> (See attached file: test3.xsd)  (See attached file: name.xsd)
>
> regards,
> John Kaputin
>
>
>
>
>              Davanum Srinivas
>              <davanum@gmail.co
>              m>                                                         To
>                                        woden-dev@ws.apache.org
>              20/10/2005 15:00                                           cc
>
>                                                                    Subject
>              Please respond to         XMLSchema
>                  woden-dev
>
>
>
>
>
>
>
>
>
> Folks,
>
> Can you please let me know how to recreate the problems you had with
> XmlSchema?
>
> Thanks,
> dims
>
> --
> Davanum Srinivas : http://wso2.com/blogs/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: woden-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: woden-dev-help@ws.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: woden-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: woden-dev-help@ws.apache.org
>
>
>


--
Davanum Srinivas : http://wso2.com/blogs/

---------------------------------------------------------------------
To unsubscribe, e-mail: woden-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: woden-dev-help@ws.apache.org


Mime
View raw message