ws-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Nichol" <snicholn...@scottnichol.com>
Subject Re: SOAP and HTTPS
Date Wed, 15 Sep 2004 00:53:17 GMT
What is the nature of your problem?  Are you running SSL code and getting errors (in which
case, what are the errors), or are you unsure of how to configure things?
Scott Nichol

Do not send e-mail directly to this e-mail address,
because it is filtered to accept only mail from
specific mail lists.
----- Original Message ----- 
From: "Daniel Herbison" <herbison@nortelnetworks.com>
To: <Soap-user@ws.apache.org>
Sent: Tuesday, September 14, 2004 6:54 PM
Subject: SOAP and HTTPS


> I'm trying to access a soap service, Java running under Tomcat, using
> Soap::Lite.  Here is the code:
> 
>  
> 
> use SOAP::Lite;
> 
>  
> 
> push @x,"userid=".$ARGV[0];
> 
> push @x,"password=".$ARGV[1];
> 
> push @x,"sip=".$ARGV[2];
> 
> push @x,"date=".$ARGV[3];
> 
> push @x,"xmlIndent=true";
> 
> $,="\t";
> 
> $\="\n";
> 
> print 'htmlParams' ,$x[0],$x[1],$x[2],$x[3];
> 
> print SOAP::Lite
> 
>         -> service('http://service...?wsdl')
> 
>         -> getIPConversations(SOAP::Data->name('htmlParams' => \@x ))
> 
>  
> 
> It works great with http and I'm now trying to get it to authenticate using
> https and a client credential file generated with the java tool keytool.
> 
> OpenSSL and Crypt-SSLeay are installed. 
> 
>  
> 
> Does anyone know how to do this?  
> 
>  
> 
> 

Mime
View raw message