ws-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Praveen Peddi" <ppe...@contextmedia.com>
Subject Re: Adding a new soap service problem
Date Fri, 24 Sep 2004 17:16:51 GMT
I got the sample from onjava.com. You can find all the related data here: 
http://www.onjava.com/pub/a/onjava/excerpt/java_xml_2_ch2/index.html?page=5.

When I executed command line I got the following output:
"Deployed Services: urn:cd-catalog"

When I ran soap client to access soap service, I get the following error:
"Error encountered: Unable to resolve target object: javaxml2.CDCatalog".

Praveen

----- Original Message ----- 
From: "Scott Nichol" <snicholnews@scottnichol.com>
To: <soap-user@ws.apache.org>
Sent: Friday, September 24, 2004 12:53 PM
Subject: Re: Adding a new soap service problem


You can deploy it through that admin page, using the command line and a 
deployment descriptor file (my preference since all the info to re-deploy 
the service is there), or by copying the serialized deployment descriptors 
file that Apache SOAP creates.  This last option is for advanced users that 
want to install the server side stuff from a single war file.

Scott Nichol

Do not send e-mail directly to this e-mail address,
because it is filtered to accept only mail from
specific mail lists.
----- Original Message ----- 
From: "Tommy Kalafut" <tommyk@tridsys.com>
To: <soap-user@ws.apache.org>
Sent: Friday, September 24, 2004 12:00 PM
Subject: RE: Adding a new soap service problem


> I am still a little confused by deployment. (I am working with a
> subcontracted prototype that uses SOAP.)  Do you also have to deploy your
> service in the Soap admin page at
> http://localhost:8081/soap/admin/index.html? (Your port number may be
> different.)
>
>
>
>
>
>
>
> Tom Kalafut
> Interchange Crew Member
> Trident Systems, Inc.
> tommyk@tridsys.com
> (703)691-7798
>
>
>
> -------------------------
>
> The opinions expressed in this email may not necessarily reflect the
> opinions of Trident Systems, Inc.
>
>   _____
>
> size=2 width="100%" align=center tabindex=-1>
>
> From: Praveen Peddi [mailto:ppeddi@contextmedia.com]
> Sent: Friday, September 24, 2004 11:54 AM
> To: soap-user@ws.apache.org
> Subject: Adding a new soap service problem
>
>
>
> Hi all,
>
> I have 5 soap services running and now I deployed a new service using
> command line tool as follows:
>
>
>
> org.apache.soap.server.ServiceManagerClient
> <http://host:port/soap/servlet/rpcrouter>
> http://host:port/soap/servlet/rpcrouter deploy NewServiceDD.xml
>
>
>
> I get no errors and even I can see the new service in the admin page. But
> when I connect to the new service using a soap client, it gives an error
> saying no service with the specified name.
>
>
>
> I am using tomcat as the server.
>
>
>
> I am sure i might be missing one simple thing. Any help would be
> appraciated.
>
>
>
> Praveen
>
>
>
>
>
> **************************************************************
> Praveen Peddi
> Sr Software Engg, Context Media, Inc.
> email:ppeddi@contextmedia.com
> Tel:  401.854.3475
> Fax:  401.861.3596
> web: http://www.contextmedia.com
> **************************************************************
> Context Media- "The Leader in Enterprise Content Integration"
>
> 


Mime
View raw message