ws-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "D Johnson" <vtmo...@home.com>
Subject RE: cannot get past install problems
Date Fri, 01 Jun 2001 22:05:06 GMT
James,

	Most install issues are environmental, (having been where you are, I know
that's the LAST
thing you probably want to hear!).. However, that being said, I've resolved
almost EVERY
issue I've ever had using

javap, to verify existance of classes and methods

and

JWhich to see WHICH class file I'm loading.. You problems might be related
to just
finding the wrong class first in a preceeding jar file.

JWhich is free, as all good things are, but I don't have a link to it handy.
Let me know if
you can't find it and I'll send you the link from work on Monday.

Good Luck, let me know if I can be of assistance. I've done 7 SOAP
installations from the ground up over
the past year and not ONE has gone through without SOME sort of issue, be it
ordering, versioning etc.

Good Luck,

=- Dj


-----Original Message-----
From: James Cooper [mailto:jwcnmr@us.ibm.com]
Sent: Friday, June 01, 2001 10:57 AM
To: soap-user@xml.apache.org
Subject: cannot get past install problems


Using: Windows 2000
Tomcat 3.2.1
xerces 1.4.0
soap 2.2

Put soap.war in tomcat\webapps
put mail.jar and activation.jar in soap\lib
set classpath to
c:\xerces\xerces.jar;c:\soap\lib\soap.jar;c:\soap\lib\mail.jar;c:
\soap\lib\activation.jar;c:\tomcat\lib\servlet.jar;.;D:
\sqllib\java\db2java.zip;D:\sqllib\java\runtime.zip;D:
\sqllib\java\sqlj.zip;D:\sqllib\bin

Modified tomcat.bat  to show
set CP=c:\xerces\xerces.jar;%CLASSPATH%;%CP%

Tomcat starts fine

You can run the SOAP administrator and deploy services, and
http://localhost:8080/soap/servlet/rpcrouter returns the expected message,
but

java org.apache.soap.server.ServiceManagerClient
http://localhost:8080/soap/servlet/rpcrouter list

causes:
Exception in thread "main" [SOAPException: faultCode=SOAP-ENV:Protocol;
msg=Unsupported response content type text/html", must be: "text/xml".
Response was:
<h1>Error: 500</h1>
<h2>Location: /soap/servlet/rpcrouter</h2><b>Internal Servlet
Error:</b><br><pre
>java.lang.NoClassDefFoundError: javax/activation/MimeTypeParseException
        at
org.apache.soap.server.http.RPCRouterServlet.doPost(RPCRouterServlet.
java:220)

etc. etc.

I guess I'll go back to SOAP 2.0 unless someone has a suggestion.


James W. Cooper
Advanced Information Retrieval and Analysis
IBM T J Watson Research Center
jwcnmr@watson.ibm.com
http://flahdo.watson.ibm.com/
http://www.research.ibm.com/people/j/jwcnmr/



---------------------------------------------------------------------
To unsubscribe, e-mail: soap-user-unsubscribe@xml.apache.org
For additional commands, email: soap-user-help@xml.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: soap-user-unsubscribe@xml.apache.org
For additional commands, email: soap-user-help@xml.apache.org


Mime
View raw message