ws-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Boylan <m...@ffsoft.com>
Subject Deploy Nightmare
Date Tue, 25 Jul 2000 23:38:51 GMT
Ugh.  I'm having a problem deploying services.  
Actually, I think there are two separate problems.  
The first is when I try to deploy from the command line:

------------------------------------------
[mark@babydoll calculator]$ java
org.apache.soap.server.ServiceManagerClient
http://localhost:8080/xml-soap/rpcrouter.jsp deploy
./DeploymentDescriptor.xml
Exception in thread "main" [SOAPException: faultCode=SOAP-ENV:Client;
msg=error parsing HTTP status line: Connection reset by peer: Connection
reset by peer; targetException=java.lang.IllegalArgumentException: error
parsing HTTP status line: Connection reset by peer: Connection reset by
peer]
	at
org.apache.soap.transport.http.SOAPHTTPConnection.send(SOAPHTTPConnection.java,
Compiled Code)
	at org.apache.soap.rpc.Call.invoke(Call.java, Compiled Code)
	at
org.apache.soap.server.ServiceManagerClient.invokeMethod(ServiceManagerClient.java,
Compiled Code)
	at
org.apache.soap.server.ServiceManagerClient.deploy(ServiceManagerClient.java,
Compiled Code)
	at
org.apache.soap.server.ServiceManagerClient.main(ServiceManagerClient.java,
Compiled Code)
[mark@babydoll calculator]$ 
------------------------------------------

The second problem is when I try to deploy from the browser, 
I cant even load the deploy.jsp page:

------------------------------------------
Error: 500

Location: /xml-soap/deploy.jsp

Internal Servlet Error:

org.apache.jasper.JasperException: Unable to compile class for
JSP/opt/tomcat/work/localhost_8080%2Fxml-soap/_0002fdeploy_0002ejspdeploy_jsp_0.java:148:
No variable NS_URI_BML_ENC defined in class org.apache.soap.Constants.
                       org.apache.soap.Constants.NS_URI_BML_ENC};
                                                ^
1 error

        at org.apache.jasper.compiler.Compiler.compile(Compiler.java,
Compiled Code)
        at org.apache.jasper.runtime.JspServlet.loadJSP(JspServlet.java,
Compiled Code)
        at
org.apache.jasper.runtime.JspServlet$JspServletWrapper.loadIfNecessary(JspServlet.java,
Compiled Code)
        at
org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(JspServlet.java,
Compiled Code)
        at
org.apache.jasper.runtime.JspServlet.serviceJspFile(JspServlet.java,
Compiled Code)
        at org.apache.jasper.runtime.JspServlet.service(JspServlet.java,
Compiled Code)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java,
Compiled Code)
        at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java,
Compiled Code)
        at
org.apache.tomcat.core.ContextManager.service(ContextManager.java,
Compiled Code)
        at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java,
Compiled Code)
        at
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java,
Compiled Code)
        at java.lang.Thread.run(Thread.java, Compiled Code)
---------------------------------------

I'm running RH6.2, tomcat 3.1, xerces 1.0.4, Blackdown JDK 1.2.2.
I tried switching to xerces 1.0.3, and got the same results.
If anyone has any insight, please post.  This is driving me nuts.

Thanks,
Mark

Mime
View raw message