ws-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mack MacKenzie" <mmacken...@rdsolutions.com>
Subject RE: Deserialization Problem
Date Tue, 11 Jul 2000 19:07:49 GMT
Hi Gerd -

I was not successful getting Apache xerces 1.0.3 to work for me
w/Apache-Tomcat.  Like you I still wound up with an exception.  (Don't
remember, might have been the same one.)

I found that by using the xerces that comes with XML4J 3.0.1 it worked fine.

Hope this helps,

   --- Mack ---


-----Original Message-----
From: Gerd Aschemann [mailto:ascheman@informatik.tu-darmstadt.de]
Sent: Tuesday, July 11, 2000 4:43 AM
To: soap-dev@xml.apache.org
Cc: soap-dev@xml.apache.org; monica_pintoa@yahoo.es;
ochipara@cse.unl.edu; soap-user@xml.apache.org
Subject: Re: Deserialization Problem


(Since you were asking on the Apache soap-dev/user lists I suppose you
ran into this problem with the Apache xml-soap impl.)

Octav Chipara wrote/schrieb:
> I trying to make a web service using SOAP and Tomcat. I'm getting a
> deserialization problem: No deserializer found to deserialize a
> http://schemas.xmlsopa.org/soap/envelope/:Paramerter using style ''
>
> I know this is a well-known issue but I did not
> find  the archive for the mails posted on this list so I will ask you for
> some suggestions how I could go about and solve the problem.

As someone else suggested, you will find the archives on


http://www.alphaworks.ibm.com/aw.nsf/discussion?ReadForm&/forum/soap4j.nsf/d
iscussion?createdocument

The problem is discussed there multiple times and seems to occur with
Xerces 1.1.1 (and should be solved with newer releases of Xerces).
The suggested solution is to use Xerces 1.0.3. However, I still
encounter the problem with Xerces 1.1.2. Switching back to Xerces
1.0.3 I encounter a new problem:

Exception in thread "main" java.lang.NoClassDefFoundError:
	org/apache/xerces/utils/Base64
	at
org.apache.soap.encoding.soapenc.Base64Serializer.<init>(Base64Serializer.ja
va:18)
        at
org.apache.soap.encoding.SOAPMappingRegistry.<init>(SOAPMappingRegistry.java
:248)
        at org.apache.soap.rpc.Call.<init>(Call.java:84)
        at org.apache.soap.rpc.Call.<init>(Call.java:89)
        at samples.addressbook.GetAllListings.main(GetAllListings.java:91)

Any ideas how to finally solve this issue?

--
Gerd Aschemann --- Aschemann@Informatik.TU-Darmstadt.de
    Veröffentlichen heißt Verändern (Carmen Thomas)


Mime
View raw message