ws-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Nichol <snicholn...@scottnichol.com>
Subject Re: Need help badly with soap apache!!!!!
Date Tue, 27 May 2003 21:31:56 GMT
Two questions

1. How have you deployed Apache SOAP on the server?  Did you create a 
webapp?  Did you change Tomcat's classpath?

2. How have you deployed your service class, newrequestv2?

On 26 May 2003 at 20:09, Henk Schipper wrote:

> Hi All,
> 
> We are implementing apache soap fase 2 now.
> Tomcat 3.3.1
> Apache Soap 2.3.1
> And the jars:
> 	- Activation.jar
> 	- bsf.jar
> 	- jaxp.jar
> 	- js.jar
> 	- mail.jar
> 	- mailapi.jar
> 	- parser.jar
> 	- xerces.jar
> ============================================================================
> =============
> The simpel soap fase 1 runs very well. No problems at all. Only 1 namespace
> used and all ok. Now we have a challange which i cannot figure out to get it
> work under apache soap
> ============================================================================
> =============
> I got 2 parts in a xml envelope (header and body):
> <?xml version="1.0" encoding="UTF-8"?>
> <SOAP-ENV:Envelope xmlns:SOAPSDK1="http://www.w3.org/2001/XMLSchema"
> xmlns:SOAPSDK2="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:SOAPSDK3="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
> 	<SOAP-ENV:Header>
> 		<hdr:xMLHeader xmlns:hdr="http://www.mynet.nl/fase2/Header-v1">
> 			<RouteInfo>
> 				<Source>
> 					<Company>C1</Company>
> 					<Department>D2</Department>
> 					<Application>My application</Application>
> 				</Source>
> 				<Destination>
> 					<Company>C2</Company>
> 					<Department>D0</Department>
> 				</Destination>
> 				<Via>
> 					<Company>C5</Company>
> 					<Department>D3</Department>
> 					<Application>My application service</Application>
> 				</Via>
> 			</RouteInfo>
> 			<MsgId>
> 				<MsgRefNr>200301080008</MsgRefNr>
> 				<MsgType>
> 					<Name>New project fase2</Name>
> 					<Version>01</Version>
> 					<Vsub>02</Vsub>
> 					<ComType>MyType</ComType>
> 					<ComElement>Request</ComElement>
> 				</MsgType>
> 				<TheTime>2003-01-01T12:08:00</TheTime>
> 				<Test>1</Test>
> 			</MsgId>
> 			<Transaction>
> 				<TransactionNr>00000300-0000-0000-C000-000000000046</TransactionNr>
> 				<Order>1</Order>
> 				<LastMsg>1</LastMsg>
> 			</Transaction>
> 		</hdr:xMLHeader>
> 	</SOAP-ENV:Header>
> 	<SOAP-ENV:Body>
> 		<dtl:xMLBody xmlns:dtl="http://www.mynet.nl/fase2/Body/newrequest-v2" >
> 			<Request>
> 				<FldR1>123</FldR1>
> 				<FldR1>2</FldR1>
> 				<FldR1>01</FldR1>
> 			</Request>
> 		</dtl:xMLBody>
> 	</SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> ============================================================================
> =============
> I got a deploymentdesciption:
> <isd:service xmlns:isd="http://xml.apache.org/xml-soap/deployment"
> id="http://www.mynet.nl/fase2/Body/newrequest-v2">
> 	<isd:provider type="java" scope="Request" methods="ProcessRequest">
> 		<isd:java class="newrequestv2" static="false"/>
> 	</isd:provider>
> 
> <isd:faultListener>org.apache.soap.server.DOMFaultListener</isd:faultListene
> r>
> 	<isd:mappings>
> 		<isd:map encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:dtl="http://www.mynet.nl/fase2/Body/newrequest-v2" qname="dtl:Request"
> xml2JavaClassName="MyDoNothingDeserializer" javaType="java.lang.String"/>
> 		<isd:map encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:a="http://schemas.xmlsoap.org/soap/encoding/" qname="a:string"
> xml2JavaClassName="org.apache.soap.encoding.soapenc.StringDeserializer"
> javaType="java.lang.String" java2XMLClassName="MyDoNothingSerializer"/>
> 	</isd:mappings>
> </isd:service>
> ============================================================================
> =============
> And the result:
> <SOAP-ENV:Envelope
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema">
> <SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server.Exception:</faultc
> ode>
> <faultstring>java.lang.NoClassDefFoundError</faultstring>
> <faultactor>/soap/fase2/newrequest-v2</faultactor>
> </SOAP-ENV:Fault>
> ============================================================================
> =============
> 
> It will not find the javaclass 'newrequestv2'. I tried all kinds of
> things... nothing.
> PLEASE help....What am i doing wrong?
> 
> 
> Thanks in advance for your help.
> 
> Henk.
> 
> 
> 
> 
> 


Scott Nichol

Do not reply directly to this e-mail address,
as it is filtered to only receive e-mail from
specific mailing lists.



Mime
View raw message