ws-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattias Jiderhamn" <matt...@expertsystem.se>
Subject RE: Serializer + deployment descriptor
Date Thu, 14 Nov 2002 07:33:51 GMT
Now I also found *why* I made the misstake.
In the /docs/guide/deploy.html#typemapping you can find
"Where encoding-uri is the URI for the encoding method (i.e.
http://schemas.xmlsoap.org/soap/encoding for the standard SOAP encoding,)"
Without the trailing /!

May I suggest a fix?

> -----Original Message-----
> From: Scott Nichol [mailto:snicholnews@scottnichol.com]
> Sent: Wednesday, November 13, 2002 6:26 PM
> To: soap-dev@xml.apache.org
> Subject: Re: Serializer + deployment descriptor
>
>
> Try putting a trailing / on the encoding:
>
>     http://schemas.xmlsoap.org/soap/encoding/
>
> instead of
>
>     http://schemas.xmlsoap.org/soap/encoding
>
> Scott Nichol
>
> ----- Original Message -----
> From: "Mattias Jiderhamn" <mattias@expertsystem.se>
> To: <soap-dev@xml.apache.org>
> Sent: Wednesday, November 13, 2002 4:12 AM
> Subject: Serializer + deployment descriptor
>
>
> > I am really, really tired of the fact that I can not get any type
> mappings
> > to work in the deployment desriptor.
> >
> > If I have the file:
> > <isd:service xmlns:isd="http://xml.apache.org/xml-soap/deployment"
> >   id="urn:ApiTest">
> >   <isd:provider type="java"
> >     scope="Application"
> >     methods="isOk getIntPair getIntArray getIntPairArray getNullObject
> > getNullArray">
> >     <isd:java class="se.exder.api.ApiTest" static="true" />
> >   </isd:provider>
> >   <isd:faultListener>
> >     org.apache.soap.server.DOMFaultListener
> >   </isd:faultListener>
> >
> >   <isd:mappings>
> >     <isd:map encodingStyle="http://schemas.xmlsoap.org/soap/encoding"
> >      xmlns:x="urn:ApiTest" qname="x:IntPair"
> >      javaType="se.exder.api.IntPair"
> >
> java2XMLClassName="org.apache.soap.encoding.soapenc.BeanSerializer"
> >
> xml2JavaClassName="org.apache.soap.encoding.soapenc.BeanSerializer"/>
> >   </isd:mappings>
> > </isd:service>
> >
> > and try to deploy it with
> >   java -classpath $CLASSPATH
> org.apache.soap.server.ServiceManagerClient
> > http://localhost/servlet/rpcrouter deploy filename.wsdd
> > The mapping is never working (client says
> > "java.lang.IllegalArgumentException: No Serializer found to serialize
> a
> > 'se.exder.api.IntPair' using encoding style
> > 'http://schemas.xmlsoap.org/soap/encoding/'")
> >
> > But if I input the exact same information in the admin page
> > (/soap/deploy.jsp) everything works just fine. (See attached
> sceenshots).
> >
> > I always undeploy the service before re-deploying. I have tried the
> latest
> > build (2002-10-27) and I am still having the same problem.
> > Why is this???
> > What can I do about it?
> >
>
>
> ------------------------------------------------------------------------
> --------
>
>
> > --
> > To unsubscribe, e-mail:   <mailto:soap-dev-unsubscribe@xml.apache.org>
> > For additional commands, e-mail: <mailto:soap-dev-help@xml.apache.org>
>
>
> --
> To unsubscribe, e-mail:   <mailto:soap-dev-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <mailto:soap-dev-help@xml.apache.org>
>
>


Mime
View raw message