ws-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilya.lipk...@kodak.com
Subject Apache SOAP 2.2 on WLS 6.1 SAXParsing error...
Date Thu, 13 Dec 2001 22:57:49 GMT
From: Ilya V Lipkind

Hello guys,

I have installed Apache SOAP v2.2 toolkit on top of WLS 6.1 following the
advise in
http://xml.apache.org/soap/faq/faq-for-WL6.1beta.html
So far, everything was working fine including examples, till I start to
pass as SOAP method parameters, relatively big XML documents (85 KB).
Smaller documents work fine.

I'm getting follow exception :
parsing error: org.xml.sax.SAXParseException: The markup in the document
preceding the root element must be well-formed.

Weblogic catch the exception and print follow message :

<Dec 13, 2001 1:32:00 PM PST> <Error> <XML> <Failed to open XML document.
Failed
 to retrieve PUBLIC id or SYSTEM id from the document. Decrease the number of ch
ar between the beginning of the document and its root element.>

I tried to pass XML document as org.w3c.dom.Element using Constants.NS_URI_LITERAL_XML encoding
and as a String using Constants.NS_URI_SOAP_ENC encoding. In both cases bigger document failed,
but smaller
works fine. The failure huppen inside Apache SOAP toolkit during parsing SOAP message, before
my code get called.
TcpTunnelGui  show valid SOAP request.

All XML documents are well formatted and successfully parsed using Apache Xerces and JDOM
parsers.

Configuration : NT sp 6, WLS 6.1 sp1, SOAP Apache 2.2, Xerces 1.4.3

Also, I would appreciate any help in debugging SOAP toolkit. Additional log messages in RPCRouterServlet.java
doesn't
do any good, because WLS catch the exception. I'm planning to use SAXExceptionHandler for
viewing the stack trace.
Any ideas would be welcome.

Ilya


Mime
View raw message