Hi,

 

For the second and subsequent reply messages, addressing headers are missing. Is there some configuration that is missing?

 

Response 1:

 

2009-01-23 11:29:42,093 DEBUG [httpclient.wire.content] (Axis2 Task) >> "<?xml version='1.0' encoding='UTF-8'?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsa="http://www.w3.org/2005/08/addressing"><SOAP-ENV:Header><wsa:To>http://10.98.196.194:7779/axis2/services/anonService1</wsa:To><wsa:ReplyTo><wsa:Address>http://www.w3.org/2005/08/addressing/none</wsa:Address></wsa:ReplyTo><wsa:MessageID>urn:uuid:6356EB113387EC53AD1232738982056</wsa:MessageID><wsa:Action>anonOutInOp</wsa:Action><wsa:RelatesTo>urn:uuid:35B6A56CBAD8D156C01232738980224</wsa:RelatesTo><wsrm:Sequence xmlns:wsrm="http://docs.oasis-open.org/ws-rx/wsrm/200702" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" soapenv:mustUnderstand="1"><wsrm:Identifier>urn:uuid:35B6A56CBAD8D156C01232738980145</wsrm:Identifier><wsrm:MessageNumber>1</wsrm:MessageNumber></wsrm:Sequence><wsrm:SequenceAcknowledgement xmlns:wsrm="http://docs.oasis-open.org/ws-rx/wsrm/200702" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" soapenv:mustUnderstand="1"><wsrm:Identifier>urn:uuid:6356EB113387EC53AD1232738981535</wsrm:Identifier><wsrm:AcknowledgementRange Lower="1" Upper="2" /></wsrm:SequenceAcknowledgement></SOAP-ENV:Header><SOAP-ENV:Body><WeatherResponse xmlns="http://www.example.org/weatherschema"><forecast xmlns="">Forecast for 'Sunnyvale, CA 94089' is foggy.</forecast></WeatherResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>"

 

Response 2: (wsa:to and other headers are missing)

 

2009-01-23 11:29:43,906 DEBUG [httpclient.wire.content] (Axis2 Task) >> "<?xml version='1.0' encoding='UTF-8'?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsa="http://www.w3.org/2005/08/addressing"><SOAP-ENV:Header><wsrm:Sequence xmlns:wsrm="http://docs.oasis-open.org/ws-rx/wsrm/200702" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" soapenv:mustUnderstand="1"><wsrm:Identifier>urn:uuid:35B6A56CBAD8D156C01232738980145</wsrm:Identifier><wsrm:MessageNumber>2</wsrm:MessageNumber></wsrm:Sequence><wsrm:SequenceAcknowledgement xmlns:wsrm="http://docs.oasis-open.org/ws-rx/wsrm/200702" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" soapenv:mustUnderstand="1"><wsrm:Identifier>urn:uuid:6356EB113387EC53AD1232738981535</wsrm:Identifier><wsrm:AcknowledgementRange Lower="1" Upper="2" /></wsrm:SequenceAcknowledgement></SOAP-ENV:Header><SOAP-ENV:Body><WeatherResponse xmlns="http://www.example.org/weatherschema"><forecast xmlns="">Forecast for 'FREMONT, CA 94089' is foggy.</forecast></WeatherResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>"

 

Thanks