ws-sandesha-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Melgar <dmel...@us.ibm.com>
Subject Re: Problem getting samples to work
Date Wed, 26 Sep 2007 03:01:45 GMT
I had commented out engaging sandesha2 to debug the problem. Once I 
re-enabled it, the ping sample worked.




David Melgar/Raleigh/IBM@IBMUS 
09/25/07 10:53 PM

To

cc
sandesha-dev@ws.apache.org
Subject
Re: Problem getting samples to work







I've waded through and found that axis2 really doesnt like the action 
being set in UserguidePingClient to "urn:wsrm:Ping". It does like 
"urn:ping". 

If I change that I then get the next ominous sounding error, 
        <soapenv:Fault> 
            <faultcode>soapenv:Client</faultcode> 
            <faultstring>RawXMLMessageReceiver can not handle this 
scenario since ServiceClass has implemented to take Non OMElement as 
method arguments.</faultstring> 
            <detail /> 
         </soapenv:Fault> 

Am I running the right level of code? 

What is the recommended set of code to try and get sandesha2 running? 
Is this the best place to be asking? 

Thanks 



David Melgar/Raleigh/IBM@IBMUS 
09/25/07 01:53 PM 


To
sandesha-dev@ws.apache.org 
cc

Subject
Problem getting samples to work









Hello, 
I'm trying to run the sample programs included with sandesha2-1.2 as 
described in http://ws.apache.org/sandesha/sandesha2/userGuide.html. I 
downloaded axis2-1.2 and sandesha2-1.2 binary images from the respective 
websites. 
I've installed axis2-1.2, sandesha2-1.2, deployed them to tomcat, created 
the SimpleService, created the client programs. I have tcpmon listening on 
8070 and routing to 8080 even though that was not stated in the user 
guide. 
When I try the ping client, I see a create sequence request go across and 
an appropriate response coming back. A ping request is then sent, but a 
fault is generated. 
        <soapenv:Fault> 
           <faultcode>soapenv:Client</faultcode> 
           <faultstring>java.util.MissingResourceException: Can't find 
resource for bundle org.apache.axis2.i18n.ProjectResourceBundle, key 
spec.FAULT_ACTION_NOT_SUPPORTED_REASON</faultstring> 
           <detail /> 
        </soapenv:Fault> 

When I try the echo client, I get the following exception 
Sep 25, 2007 1:48:24 PM 
org.apache.axis2.transport.http.server.DefaultConnectionListenerFailureHandler 
failed 
WARNING: Attempt number 1 of 10 to reestalish connection listener 
org.apache.axis2.transport.http.server.DefaultConnectionListener@8d0a11 
due to failure 
java.net.BindException: Address already in use 

What address is it referring to? 
In this case a CreateSequence request is sent, but no response is 
received. 

Any ideas what maybe wrong? 
Thanks 

Mime
View raw message