ws-jaxme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Wiedmann <jochen.wiedm...@gmail.com>
Subject Re: JaxMe version question
Date Thu, 03 Feb 2005 12:34:31 GMT
On Wed, 2 Feb 2005 18:16:28 -0800, Jeff Moritz <moritz@caymas.com> wrote:

> I'd like to use JaxMe on my project, but my boss won't consider using any
> library that is not yet at the 1.0 or higher release level. 

I have heard that this nonsense exists, but it's still hard to believe.

This project has specified "1.0" as "We are now implementing all
features required by JAXB 1.0". Unfortunately we are far from that
goal, so the answer is probably as evil as "years".

If we would define (like a commercial vendor) 1.0 as "professional
quality" (in other words: "gives us more money than it costs us
support), then 0.3 would be it. Please note the following: The 0.3
branch is in very active maintenance. All incoming bugreports are
compared for applicability to the HEAD branch and to the 0.3 branch.
For example, since 0.3.1 we already have several bug fixes. In fact,
it could be time for 0.3.2.

In other words: If your boss defines "1.0" as "stable and supported",
he'll get what he want: We take the heavy work of maintaining multiple
branches in order to ensure that. If he defines it as "impresses me",
then I can't help.


Jochen


-- 
Sum. Cogitone?

---------------------------------------------------------------------
To unsubscribe, e-mail: jaxme-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: jaxme-dev-help@ws.apache.org


Mime
View raw message