ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wladislaw Mitzel <mit...@tawadi.de>
Subject wss4j 2_0_x-fixes branch - tests depend on system locale
Date Sun, 23 Aug 2015 23:55:51 GMT
Hi,

I am trying to run the tests on wss4j in the 2_0_x-fixes branch. There
are two issues which cause errors during my tests. Are there resources
for developer which describe the required steps to set up an development
environment? The issues I am current facing are:

* Some asserts are comparing messages in thrown exceptions. These differ
in case of a non en_US locale. In order to execute the tests I've had to
change my system locale as I could not manage to override it for the
maven build. Do you have another (cleaner) approach?

* When running "mvn install" from the command line the following test
fails. When I run this test as jUnit test inside Eclipse it succeeds. It
also succeeds when running mvn install and stepping through the code
while debugging. Do you have any idea what is going wrong?

testMaximumAllowedTransformsPerReference(org.apache.wss4j.stax.test.VulnerabliltyVectorsTest)

Time elapsed: 1.096 sec  <<< FAILURE!
java.lang.AssertionError: Expected XMLStreamException
    at org.junit.Assert.fail(Assert.java:88)
    at
org.apache.wss4j.stax.test.VulnerabliltyVectorsTest.testMaximumAllowedTransformsPerReference(VulnerabliltyVectorsTest.java:362)

Kind regards,
Wladislaw Mitzel

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message