ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asiri Liyana Arachchi <asiriw...@gmail.com>
Subject Axiom test cases doesn't run
Date Sat, 12 Oct 2013 14:08:45 GMT
Hi all,

Im working on an Apache Axiom Project. I've tried to run some test cases
that are already in the axiom(for an example
org.apache.axiom.ts.om.xpath.TestAddNamespaces.java
)

. But every time they give this error. (saying that corresponding class has
no public constructor TestCase )

    junit.framework.AssertionFailedError: Class
org.apache.axiom.ts.om.builder.TestGetDocumentElementWithIllFormedDocument
has no public constructor TestCase(String name) or TestCase()
    at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:83)
    at org.junit.runner.JUnitCore.run(JUnitCore.java:157)
    at com.intellij.junit4.JUnit4IdeaTestRunner.startRunnerWithArgs(JUnit4IdeaTestRunner.java:77)
    at com.intellij.rt.execution.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:195)
    at com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:63)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at com.intellij.rt.execution.application.AppMain.main(AppMain.java:120)

       Process finished with exit code 255

I've successfully built axiom  with dependencies with passing all the Test
cases. I've tried importing projects on both eclipse and intellijidea IDEs.
Still I don't have an idea about what I'm doing wrong.

I'll appreciate if some one can help me on this.

Thank

Mime
View raw message