ws-commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject [Axiom] Dropping JDK 1.4 support?
Date Sat, 01 May 2010 11:37:44 GMT
All,

Up to version 1.2.8, Axiom has always supported Java 1.4. It is clear
that supporting that Java version becomes increasingly difficult,
because some of the dependencies require Java 1.5. For example,  in
r754991 I've updated the Geronimo dependencies (activation and
javamail) because the versions used in 1.2.8 had some bugs that caused
issues to Axiom. However, these dependencies have been built with Java
1.5. There may also be some Maven plugins that fail on Java 1.4.

In his recent change (r939925), Amila also introduced code that
depends on java.util.UUID, which was introduced in Java 1.5. There may
be other changes since 1.2.8 that only work with Java 1.5. Therefore
it's time to take a decision about Java 1.4 support.

WDYT?

Andreas

Mime
View raw message