ws-axis-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sam...@apache.org
Subject svn commit: r376145 - /webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c
Date Thu, 09 Feb 2006 01:54:41 GMT
Author: samisa
Date: Wed Feb  8 17:54:39 2006
New Revision: 376145

URL: http://svn.apache.org/viewcvs?rev=376145&view=rev
Log:
Fixed the problem of server not starting when addressing module not present in axis2.xml

Modified:
    webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c

Modified: webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c
URL: http://svn.apache.org/viewcvs/webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c?rev=376145&r1=376144&r2=376145&view=diff
==============================================================================
--- webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c (original)
+++ webservices/axis2/trunk/c/modules/core/deployment/conf_builder.c Wed Feb  8 17:54:39 2006
@@ -300,7 +300,7 @@
                                 axis2_om_children_qname_iterator_t *module_refs) 
 {
     axis2_conf_builder_impl_t *builder_impl = NULL;
-    axis2_status_t status = AXIS2_FAILURE;
+    axis2_status_t status = AXIS2_SUCCESS;
     
     AXIS2_ENV_CHECK(env, AXIS2_FAILURE);
     AXIS2_PARAM_CHECK((*env)->error, module_refs, AXIS2_FAILURE);
@@ -332,6 +332,7 @@
             axis2_char_t *ref_name = NULL;
             
             ref_name = AXIS2_OM_ATTRIBUTE_GET_VALUE(module_ref_att, env);
+            AXIS2_LOG_DEBUG((*env)->log, AXIS2_LOG_SI, "module %s found in axis2.xml",
ref_name);
             qrefname = axis2_qname_create(env, ref_name, NULL, NULL);
             status = AXIS2_DEP_ENGINE_ADD_MODULE(conf_builder->desc_builder->
                 engine, env, qrefname);



Mime
View raw message