wicket-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lucast <lucastol...@hotmail.com>
Subject Re: Panels not refreshing when calling AjaxRequestTarget.add(), only in production mode
Date Wed, 03 Jun 2015 12:40:25 GMT
Hi Sven,
Thank you for your reply.

Yes, I call formComponentPanel#setOutputMarkupPlaceholderTag(true) on all
elements involved with the AjaxRequestTarget.

I'm still trying to get to the bottom of this.

What I am baffled about is why it doesn't work on production mode when it
works without any problems in development mode.

when on production mode, on firebug, I get the following error:

*Wicket.Ajax: Wicket.Ajax.Call.processComponent: Component with id [[id29]]
was not found while trying to perform markup update. Make sure you called
component.setOutputMarkupId(true) on the component whose markup you are
trying to update.*

I have called setOutputMarkupPlaceholderTag(true) on the panel I am adding
to AjaxRequestTarget.

So the question is, has anyone experienced that a panel is refreshed when
running a wicket app in development mode, and that the panel is not
refreshed when running a wicket app in production mode?

Thanks, once more,
Lucas

--
View this message in context: http://apache-wicket.1842946.n4.nabble.com/Panels-not-refreshing-when-calling-AjaxRequestTarget-add-only-in-production-mode-tp4671035p4671041.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@wicket.apache.org
For additional commands, e-mail: users-help@wicket.apache.org


Mime
View raw message