wicket-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lorne Malvo <caffeineindu...@gmail.com>
Subject Re: Problem adding CSS resources in Wicket 6
Date Sun, 27 Jul 2014 18:37:24 GMT

Thank you, Sven, very helpful!
However, unfortunately, the read and your suggestion didn't solve my
problem.
I'm upgrading a site from Wicket 4 to Wicket 6, and I thought that the
version numbers in the links to the CSS resources where the reason for
browsers not finding my CSS resources.
But it seems that was not the problem after all - the problem seems to be
that the URLs in the links to my CSS resources in the HTML headers are
pointing to different locations that they were before.
For example:

In Wicket 4, the link to a css stylesheet was rendered like this:

<link rel="stylesheet" type="text/css"
href="resources/com.myFantasticDomain.web.pages.home.HomePage/HomePage.css"
/>

In Wicket 6, the link to the same resource (haven't changed anything about
the actual resource), the same link is rendered like this.

<link rel="stylesheet" type="text/css"
href="./wicket/resource/com.myFantasticDomain.web.pages.home.HomePage/HomePage.css"
/>

In Wicket 4, the stylesheet is found by browsers. In Wicket 6, it's not.

Would you know what the problem is here?

Thank you so much! It helps a lot.



--
View this message in context: http://apache-wicket.1842946.n4.nabble.com/Problem-adding-CSS-resources-in-Wicket-6-tp4666749p4666759.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@wicket.apache.org
For additional commands, e-mail: users-help@wicket.apache.org


Mime
View raw message