wicket-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mashleyttu <mash...@gmail.com>
Subject Wicket Can't Find Component Error
Date Tue, 13 May 2014 13:16:31 GMT
Hello All,

Maybe a couple times a week we get a wicket error stating: Unable to find
component with id "XZY" in ..... Found with similar names: "" when a user
submits one of our forms (we have lots, it has happened on different ones).
We have had a couple user tell us they were sent to our custom error page,
and had to re-complete the form. 

We are having a hard time re-producing this error. My thought is somehow our
page map is getting evicted, because I do not believe it has anything to do
with session timeout. We do not implement any MaxPageMap or custom eviction
strategies. We are using whatever the wicket default is. 

My other thought is on certain request we are getting serialization errors,
but I'm not seeing any in our tomcat logs.

Our site currently has anywhere from about 5 - 20 users on at any given
time. It is very small, and this only happens 2 or 3 times a week. My
concern is as we grown this will happen more often.

Any ideas on what could be occurring? This is an older wicket app built on
wicket 1.5.10. 

Thanks,
Matt

PS. We also get errors a few times a day telling us page number 0 or 1 or 4,
etc has expired. These always occur when there is no active session. My
guess is it could be a bot or something trying to access one of our sites
URLs. I'm less concerned about this error, but still curious.

--
View this message in context: http://apache-wicket.1842946.n4.nabble.com/Wicket-Can-t-Find-Component-Error-tp4665810.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@wicket.apache.org
For additional commands, e-mail: users-help@wicket.apache.org


Mime
View raw message