wicket-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reiche, Andreas" <Andreas.Rei...@lgln.niedersachsen.de>
Subject Problem with gif Indicator after call of wicketAjaxGet
Date Mon, 19 Mar 2012 08:17:21 GMT
Hi,
I have a problem with the rendering of animated gifs after a call to
wicketAjaxGet.
I have the following situation.
In a webPage i have an AjaxLink which basicly returns an on-the-fly
created pdf Document for download.
As the generation needs some time i show an animated gif to the user to
inform him that the server is still busy.

The AjaxLink calls a javascript function with the callback URL of an
AbstractDefaultAjaxBehavior. 
The javascript function puts some parameters to the callback URL and
calls wicketAjaxGet.
In the AbstractDefaultAjaxBehavior's respond method i take the URL
Parameters and create the pdf.(Taken fro WIKI)

This works fine for the first time. The gif Animation works and i get
the PDF for download.

But after that if i click the AjaxLink again the gif Animation is not
animated anymore.
It just shows the first frame of the animation.
The same for another animated gif in another component in the page (it's
a OpenLayersMap added through WicketOpenLayers integration).

It will only work after a complete reload of the page (which is not an
option, because of the state of the openLayersMap).

As i'm not a javaScript guru, can anybody advise were to look for that
the gif is not animated anymore?

Thanks
Andreas Reiche


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@wicket.apache.org
For additional commands, e-mail: users-help@wicket.apache.org


Mime
View raw message