wicket-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rawe <ralph.wey...@dachser.com>
Subject Re: Markup not found when upgrading from 1.4.18 to 1.5
Date Fri, 02 Mar 2012 09:32:47 GMT
Hi,

you wrote
/>>  ... you should pass the
>>  "form" as parent container of the fragment instance. /

The problem is that I have multiple fragments within my form.
And if I pass the form as parent container for each fragment I get an
"... child already exists..." exception.

That's why I'm inserted additional div tags before each fragment which works
fine in Wicket 1.4
/<div wicket:id="contentFragment1" />
<wicket:fragment wicket:id="orderFragment1">    
    <fieldset> ...</fieldset>
</wicket:fragment>/

When I try to embed the fragment in my div
/<div wicket:id="contentFragment1" > ...here fragment ... </div>/

I get the exception:
/Close tag not found for tag: <div wicket:id="contentFragment1">. For
OrderFragment1 Components only raw markup is allow in between the tags but
not other Wicket Component
/

I'm without an idea :-(

ralph

--
View this message in context: http://apache-wicket.1842946.n4.nabble.com/Markup-not-found-when-upgrading-from-1-4-18-to-1-5-tp4431186p4437937.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@wicket.apache.org
For additional commands, e-mail: users-help@wicket.apache.org


Mime
View raw message