wicket-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Meier <s...@meiers.net>
Subject Re: taking the I out of Interface
Date Sun, 04 Oct 2009 16:33:03 GMT
Hi Matej,

I don't know how my suggestion is related to seriousness, you don't have 
to question my Java 101.

I was specifically referring to your statement:

 >ObjectModel sounds like a really good name to me because it says what 
it does.
 >Holds single object.

I thought you wanted to emphasize *single*, which doesn't fit for many 
cases where Wicket components access a list of objects through their 
model. I know that a collection object is still a single instance but 
semantically it's 'many'. BTW we had this discussion about introducing a 
specialized collection model a few months ago.

Every model provides access to an object, so the emphasis can't be on 
*object* either.

If you want to stress the fact, that the current Model class *holds* an 
object, then why don't you suggest to rename it to HoldModel?

Regards

Sven

Matej Knopp wrote:
> On Sun, Oct 4, 2009 at 5:47 PM, Sven Meier <sven@meiers.net> wrote:
>   
>> So ObjectModel will hold a single object only? What about lists and
>> collections?
>>     
> Are you serious? A collection is still one instance. It doesn't matter
> how many references it holds.
>
> -Matej
>   
>> IMHO the "Object.." prefix has no benefit.
>>
>> Why not drop the Model class altogether?
>> Its static helper methods could be located in a new non-instantiable class
>> Models (note the trailing 's') because there's nothing more exciting the
>> Model class currently provides.
>>
>> My 2 cents
>>
>> Sven
>>
>>
>> Matej Knopp wrote:
>>     
>>> Should we rename IModel to Model we would also have to rename Model to
>>> something. ObjectModel sounds like a really good name to me because it
>>> says what it does. Holds single object.
>>>
>>> Locator sounds really weird. I think renaming Model to Locator would
>>> be hell lot more confusing than renaming IModel to Model.
>>>
>>> -Matej
>>>
>>> On Sun, Oct 4, 2009 at 3:19 PM, Martin Grigorov <mcgregory@e-card.bg>
>>> wrote:
>>>
>>>       
>>>> +1 for removing 'I'. I personally do like it but since this is what the
>>>> committers prefer than I'm fine.
>>>>
>>>> -1 for renaming Model to anything else.
>>>> @Erik: it'd be interesting to be at a course of jWeekend where you'll
>>>> explain to the attendees "Wicket consists of components, models, ... and
>>>> the basic model is Locator (and all implementations end with **Model)".
>>>> I'll find it confusing.
>>>> I hope Wicket 1.5 will not rename all existing Model implementations.
>>>>
>>>> A side note: some third party projects already depends on 'I' classes.
>>>> For example Terracotta depends on IClusterable for its Wicket module.
>>>> Take this into account as well.
>>>>
>>>> El dom, 04-10-2009 a las 13:55 +0200, Erik van Oosten escribió:
>>>>
>>>>         
>>>>> I agree, the I is useless. Provided there is a good migration I'd say:
>>>>> +1.
>>>>>
>>>>> I also agree with Martin, lets change IModel to Locator while we're at
>>>>> it!
>>>>>
>>>>> Regards,
>>>>>     Erik.
>>>>>
>>>>>
>>>>> Igor Vaynberg wrote:
>>>>>
>>>>>           
>>>>>> is it perhaps time to take the I out of our interface names? wicket
>>>>>> has been the only project i have ever worked on/used that follows
this
>>>>>> convention, is it time for a change?
>>>>>>
>>>>>> this is not meant as a flamewar about which convention is teh
>>>>>> aw3s0m3st, simply a discussion of whether or not we should switch.
>>>>>>
>>>>>> -igor
>>>>>>
>>>>>>
>>>>>>             
>>>>>           
>>>>         
>>     


Mime
View raw message