wicket-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Makundi <martin.maku...@koodaripalvelut.com>
Subject Re: taking the I out of Interface
Date Sun, 04 Oct 2009 16:20:44 GMT
+1 data proxy or model proxy or proxymodel or wrapper model

2009/10/4 Jeremy Thomerson <jeremy@wickettraining.com>:
> On Sun, Oct 4, 2009 at 8:45 AM, Matej Knopp <matej.knopp@gmail.com> wrote:
>
>> Should we rename IModel to Model we would also have to rename Model to
>> something. ObjectModel sounds like a really good name to me because it
>> says what it does. Holds single object.
>>
>> Locator sounds really weird. I think renaming Model to Locator would
>> be hell lot more confusing than renaming IModel to Model.
>>
>
>
> I think he meant rename IModel to Locator.  I think that Locator or
> DataProxy or something more accurately describes it (nobody ever understands
> IModel right off the bat).  But I don't think changing it is worth the costs
> it would incur.
>
> --
> Jeremy Thomerson
> http://www.wickettraining.com
>

Mime
View raw message