wicket-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Funk <mafulaf...@googlemail.com>
Subject Re: taking the I out of Interface
Date Sun, 04 Oct 2009 19:44:32 GMT

Am 04.10.2009 um 20:33 schrieb Erik van Oosten:

> Martin Grigorov wrote:
>> @Erik: it'd be interesting to be at a course of jWeekend where you'll
>> explain to the attendees "Wicket consists of components,  
>> models, ... and
>> the basic model is Locator (and all implementations end with  
>> **Model)".
>> I'll find it confusing. I hope Wicket 1.5 will not rename all  
>> existing Model implementations.
> See earlier threads about this. Martin did not come with this  
> suggestion out of the blue.
well, yes your right its not a statement I'd say I'm the originator of.
'Pro Wicket'  comes to that conclusion:
http://books.google.de/books?id=bA8yTZIZQCsC&lpg=PA6&ots=mmvCTadLn7&dq=wicket%20model%20misnomer&pg=PA6#v

=onepage&q=wicket%20model%20misnomer&f=false
also WIA does so on page 41 (sorry no online source for that).
Though not being the originator, I very much agree with the statement.  
Esp. the IModel I find problematic. I myself might have gotten used to  
it, but I've noticed on the job that this naming is something novice  
programmers
tend to stumble (a little bit) over.
Calling IModel something like Locator, would give us a chance for  
other renamings too. LoadableDetachableModel  could be renamed to  
LoadingDetachingLocator.

mf


> Just a brief summary: in any non-Wicket application the term 'model'  
> refer to objects containing business data, often entities. In Wicket  
> apps these are called model-objects. So, Wicket's models are not  
> really 'model's but a 'proxy', a 'locator' or whatever that hide the  
> 'real' model.
>
> So I would explain something like: "Wicket consist of components and  
> locators (and all implementations of locator end with **Locator as  
> they have been renamed too). The locators provide access to your  
> business data, the models."
>
> And then I would go: "For those that still work with pre-1.5 this  
> will be hellishly confusing as they were mistakenly called model and  
> model-object before."
>
>
> Jeremy Thomerson wrote:
>> I think he meant rename IModel to Locator.  I think that Locator or
>> DataProxy or something more accurately describes it
> I like DataProxy too.
>> (nobody ever understands
>> IModel right off the bat).  But I don't think changing it is worth  
>> the costs
>> it would incur.
>>
> Well, if we can drop the 'I', we could drop IModel as well....
> But you are right, it is a big change /which can only be done if  
> there is a good migration path/.
>
> So lets please go to the original subject and forget about this.
>
> Regards,
>   Erik.
>
>
> -- 
> Erik van Oosten
> http://www.day-to-day-stuff.blogspot.com/
>


Mime
View raw message