wicket-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl-Eric Menzel <cm.wic...@users.bitforce.com>
Subject Re: taking the I out of Interface
Date Sun, 04 Oct 2009 22:33:18 GMT
> Calling IModel something like Locator, would give us a chance for  
> other renamings too. LoadableDetachableModel  could be renamed to  
> LoadingDetachingLocator.


Locator *might* have been a good name for what we now call Model, had
it been introduced right from the start, but I doubt even that. I offer
two arguments against ever changing this now, though:
 - A Model is a well-known concept in software engineering, and
   Wicket's usage matches that of Swing.
 - Model is an entrenched name by now. Renaming it now would confuse
   everybody and their dog, including newcomers who read old
   documentation or existing books.

I don't really care one way or another about moving away from the
I-convention with interfaces. I don't like it, it's not "standard", but
it's at least a pattern that almost everybody has heard of. I don't see
any pressing need to move away from it, so I'm maybe -0.1 here :-)

If the I is removed and Model needs to be renamed so as not to collide
with the ex-IModel, I think ObjectModel or DefaultModel would be
suitable names.


View raw message