wicket-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gwyn Evans" <gwyn.ev...@gmail.com>
Subject Re: wicket iolite
Date Thu, 01 May 2008 08:45:47 GMT
Hmm - I had some problems myself running it, but I'm not sure if that
was Maven or what...  I normally have a corporate proxy repo (running
Artifactory) as a mirror, but I needed to remove that before I could
get it downloaded but having done so, it's looking interesting, so
thanks!

/Gwyn

On Wed, Apr 30, 2008 at 11:42 AM, Nino Saturnino Martinez Vazquez Wael
<nino.martinez@jayway.dk> wrote:
> Okay thanks:) Just me screwing around and forgetting params..
>
>
>
>  David Bernard wrote:
>
> > use -DremoteRepositories=http://wicketstuff.org/maven/repository
> > it works on my box
> >
> > /davidB
> >
> > On Wed, Apr 30, 2008 at 7:29 AM, Nino Saturnino Martinez Vazquez Wael <
> > nino.martinez@jayway.dk> wrote:
> >
> >
> >
> > > Anybody got any clues? IT does work when using it locally, I guess it
> > > would work too if I got it published to maven central repo..
> > >
> > >
> > > Nino Saturnino Martinez Vazquez Wael wrote:
> > >
> > >
> > >
> > > > nope it's still the same using this command line:
> > > >
> > > > mvn org.apache.maven.plugins:maven-archetype-plugin:1.0-alpha-7:create
> > > > -DarchetypeGroupId=org.apache.wicket
> > > > -DarchetypeArtifactId=wicket-archetype-iolite
> > > > -DarchetypeVersion=1.3-SNAPSHOT  -DremoteRepositories=
> > > > http://wicketstuff.org/maven -DgroupId=com.mycompany
> > > > -DartifactId=ioliteTest01
> > > >
> > > > Works like a snug if I install the archetype and run it locally...
> > > >
> > > > David Bernard wrote:
> > > >
> > > >
> > > >
> > > > > Nino,
> > > > >
> > > > > it's a "bug" with the version 2 of maven-archetype-plugin.
> > > > > try with an explicit version
> > > > >  mvn
> > > > > org.apache.maven.plugins:maven-archetype-plugin:1.0-alpha-7:create
> ....
> > > > >
> > > > > /davidB
> > > > >
> > > > > Nino Saturnino Martinez Vazquez Wael wrote:
> > > > >
> > > > >
> > > > >
> > > > > > I am of course only asking about 2, as it seems that we will
have
> to
> > > > > > wait for the next release of maven to helpout with number 1..
> > > > > >
> > > > > > Nino Saturnino Martinez Vazquez Wael wrote:
> > > > > >
> > > > > >
> > > > > >
> > > > > > > Hi
> > > > > > >
> > > > > > > Im having trouble on serveral front's with the upcomming
> archetype
> > > > > > > wicket iolite[1].
> > > > > > >
> > > > > > > Problems
> > > > > > >
> > > > > > >  1. multiple projects in a archetype (currently im including
all
> > > > > > >    source as resources, which makes it unable to use specified
> > > > > > >    packagenames)
> > > > > > >  2. I cant seem to use the archetype directly from wicketstuff
> > > > > > > maven
> > > > > > >
> > > > > > > Im using this command line with maven:
> > > > > > >
> > > > > > > mvn archetype:create -DarchetypeGroupId=org.apache.wicket
> > > > > > > -DarchetypeArtifactId=wicket-archetype-iolite
> > > > > > > -DarchetypeVersion=1.3-SNAPSHOT -DremoteRepositories=
> > > > > > > http://wicketstuff.org/maven^ -DgroupId=com.mycompany
> > > > > > > -DartifactId=myproject
> > > > > > >
> > > > > > > In bamboo I've entered this "mvn clean deploy -U", and
I can see
> > > > > > > that the archetype are available at wicketstuf[2]. I've
also
> entered the
> > > > > > > distribution management in my pom:
> > > > > > >
> > > > > > > <distributionManagement>
> > > > > > >      <snapshotRepository>
> > > > > > >          <id>repo</id>
> > > > > > >          <name>Local Bamboo/Tomcat repository</name>
> > > > > > >          <url>
> > > > > > >              file:/home/wicket/tomcat/webapps/maven/repository/
> > > > > > >          </url>
> > > > > > >          <uniqueVersion>false</uniqueVersion>
> > > > > > >      </snapshotRepository>
> > > > > > >      <repository>
> > > > > > >          <id>repo</id>
> > > > > > >          <name>Local Bamboo/Tomcat repository</name>
> > > > > > >          <url>
> > > > > > >              file:/home/wicket/tomcat/webapps/maven/repository/
> > > > > > >          </url>
> > > > > > >          <uniqueVersion>false</uniqueVersion>
> > > > > > >      </repository>
> > > > > > >
> > > > > > >  </distributionManagement>
> > > > > > >
> > > > > > > So the question are what's wrong?
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > [1]=
> > > > > > >
> http://wicketstuff.org/confluence/display/STUFFWIKI/Wicket-Iolite
> > > > > > > [2]
> > > > > > >
> http://wicketstuff.org/maven/repository/org/apache/wicket/wicket-archetype-iolite/
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > > --
> > > -Wicket for love
> > >
> > > Nino Martinez Wael
> > > Java Specialist @ Jayway DK
> > > http://www.jayway.dk
> > > +45 2936 7684
> > >
> > >
> > >
> > >
> >
> >
> >
>
>  --
>
>  -Wicket for love
>
>  Nino Martinez Wael
>  Java Specialist @ Jayway DK
>  http://www.jayway.dk
>  +45 2936 7684
>
>

Mime
View raw message