whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiss Tibor <kiss.ti...@gmail.com>
Subject Re: CassandraServiceTest integration test does not complete
Date Wed, 03 Nov 2010 19:17:50 GMT
Hi Tom,

I tried with a fresh checkout from trunk.
I compiled a 0.3.0-incubating-SNAPSHOT version of the modules by mvn install

Unfortunately I see on the instances a
/tmp/computeserv/computeserv.sh

> #!/bin/bash
> set +u
> shopt -s xpg_echo
> shopt -s expand_aliases
> PROMPT_COMMAND='echo -ne "\033]0;computeserv\007"'
> export PATH=/usr/ucb/bin:/bin:/sbin:/usr/bin:/usr/sbin
> export INSTANCE_NAME='computeserv'
> export INSTANCE_NAME='computeserv'
> export INSTANCE_HOME='/tmp/computeserv'
> export LOG_DIR='/tmp/computeserv'
> cd $INSTANCE_HOME.,
> #!/bin/bash
> set +u
> shopt -s xpg_echo
> shopt -s expand_aliases
> unset PATH JAVA_HOME LD_LIBRARY_PATH
> function abort {
>    echo "aborting: $@" 1>&2
>    exit 1
> }
> export PATH=/usr/ucb/bin:/bin:/sbin:/usr/bin:/usr/sbin
> wget -qO/usr/bin/runurl run.alestic.com/runurl
> chmod 755 /usr/bin/runurl
> runurl
> http://whirr.s3.amazonaws.com/0.1.0%2B23/apache/cassandra/post-configure-c ec2 10.122.54.66
> exit 0
>
> exit 0
>

which runs
runurl
http://whirr.s3.amazonaws.com/0.1.0%2B23/apache/cassandra/post-configure -c
ec2 10.122.54.66

So this is the problem! It is a different url.

Maybe I clean it up the local maven repo and rerun the test, because I had
to use the offline mode for this latest run....

Cheers,
Tibor


On Wed, Nov 3, 2010 at 6:00 PM, Tom White <tom.e.white@gmail.com> wrote:

> The test passed and terminated the instances for me. Can you try again
> with a fresh checkout from trunk?
>
> Cheers
> Tom
>
> On Wed, Nov 3, 2010 at 9:55 AM, Tom White <tom.e.white@gmail.com> wrote:
> > Hi Tibor,
> >
> > The -c problem could be because the post-configure script is not
> > expecting it (the cloud provider) to be passed - perhaps it is an old
> > version of the script. Are you using trunk? As Patrick said, things
> > have moved around a bit since branching for the release yesterday. You
> > should be using version 0.3.0-incubating-SNAPSHOT (in pom.xml), which
> > retrieves
> http://whirr.s3.amazonaws.com/0.3.0-incubating-SNAPSHOT/apache/cassandra/post-configure
> .
> >
> > I'm running the Cassandra test now to see if I can reproduce the problem.
> >
> > Cheers,
> > Tom
> >
>

Mime
View raw message