whirr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Werner Buck (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WHIRR-674) Whirr installation fails to install java on ec2 machine
Date Wed, 14 Aug 2013 10:36:49 GMT

    [ https://issues.apache.org/jira/browse/WHIRR-674?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13739500#comment-13739500
] 

Werner Buck commented on WHIRR-674:
-----------------------------------

Hi, I can reproduce this by running a cluster of 3 zookeeper on either Amazon or Openstack
with different ubuntu AMIs (12.04.2 and 13.04).
What's strange is that java installation goes through with one node and not the other two
during bootstrapping.
This is however not an error of java but rather of the package management

I logged in and tried to install:
root@test-55ffb-f86:/etc/apt# apt-get install openjdk-6-jdk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b27-1.12.6-1ubuntu0.13.04.2) but it is not
going to be installed
                 Recommends: libxt-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@test-55ffb-f86:/etc/apt#

Upon further investigation I found that it is not possible to install ANY packages.

However, once I executed apt-get update all was well and could be executed.

This leads me to believe there is a race condition between the cloud-init mirror selection
and the bootstrap command process.
Based on the following log you can clearly see that several repo's are missing:


Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Hit http://archive.ubuntu.com precise Release.gpg
Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]
Get:3 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:4 http://archive.ubuntu.com precise Release [49.6 kB]
Get:5 http://archive.ubuntu.com precise-updates Release [49.6 kB]
Get:6 http://security.ubuntu.com precise-security/main i386 Packages [320 kB]
Get:7 http://archive.ubuntu.com precise/main i386 Packages [1,274 kB]
Get:8 http://security.ubuntu.com precise-security/restricted i386 Packages [4,620 B]
Get:9 http://security.ubuntu.com precise-security/universe i386 Packages [83.7 kB]
Get:10 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,371 B]
Get:11 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:12 http://security.ubuntu.com precise-security/multiverse TranslationIndex [71 B]
Get:13 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]
Get:14 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Get:15 http://security.ubuntu.com precise-security/main Translation-en [148 kB]
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Get:16 http://security.ubuntu.com precise-security/universe Translation-en [51.8 kB]
Get:17 http://archive.ubuntu.com precise/restricted i386 Packages [8,431 B]
Get:18 http://archive.ubuntu.com precise/universe i386 Packages [4,796 kB]
Get:19 http://archive.ubuntu.com precise/multiverse i386 Packages [121 kB]
Get:20 http://archive.ubuntu.com precise/main TranslationIndex [3,706 B]
Get:21 http://archive.ubuntu.com precise/multiverse TranslationIndex [2,676 B]
Get:22 http://archive.ubuntu.com precise/restricted TranslationIndex [2,596 B]
Get:23 http://archive.ubuntu.com precise/universe TranslationIndex [2,922 B]
Get:24 http://archive.ubuntu.com precise-updates/main i386 Packages [692 kB]
Get:25 http://archive.ubuntu.com precise-updates/restricted i386 Packages [10.0 kB]
Get:26 http://archive.ubuntu.com precise-updates/universe i386 Packages [215 kB]
Get:27 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [13.8 kB]
Get:28 http://archive.ubuntu.com precise-updates/main TranslationIndex [3,564 B]
Get:29 http://archive.ubuntu.com precise-updates/multiverse TranslationIndex [2,605 B]
Get:30 http://archive.ubuntu.com precise-updates/restricted TranslationIndex [2,461 B]
Get:31 http://archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]
Get:32 http://archive.ubuntu.com precise/main Translation-en [726 kB]
Get:33 http://archive.ubuntu.com precise/multiverse Translation-en [93.4 kB]
Get:34 http://archive.ubuntu.com precise/restricted Translation-en [2,395 B]
Get:35 http://archive.ubuntu.com precise/universe Translation-en [3,341 kB]
Get:36 http://archive.ubuntu.com precise-updates/main Translation-en [304 kB]
Get:37 http://archive.ubuntu.com precise-updates/multiverse Translation-en [7,834 B]
Get:38 http://archive.ubuntu.com precise-updates/restricted Translation-en [2,432 B]
Get:39 http://archive.ubuntu.com precise-updates/universe Translation-en [125 kB]
Fetched 12.5 MB in 11s (1,070 kB/s)


The node that worked correctly had the following apt-get update log during the bootstrap process:

Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]
Hit http://nova.clouds.archive.ubuntu.com precise Release.gpg
Get:3 http://nova.clouds.archive.ubuntu.com precise-updates Release.gpg [198 B]
Hit http://nova.clouds.archive.ubuntu.com precise Release
Get:4 http://nova.clouds.archive.ubuntu.com precise-updates Release [49.6 kB]
Get:5 http://security.ubuntu.com precise-security/main Sources [84.9 kB]
Get:6 http://nova.clouds.archive.ubuntu.com precise/main Sources [934 kB]
Get:7 http://security.ubuntu.com precise-security/universe Sources [28.0 kB]
Get:8 http://security.ubuntu.com precise-security/main i386 Packages [320 kB]
Get:9 http://security.ubuntu.com precise-security/universe i386 Packages [83.7 kB]
Get:10 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:11 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Get:12 http://nova.clouds.archive.ubuntu.com precise/universe Sources [5,019 kB]
Get:13 http://security.ubuntu.com precise-security/main Translation-en [148 kB]
Get:14 http://security.ubuntu.com precise-security/universe Translation-en [51.8 kB]
Hit http://nova.clouds.archive.ubuntu.com precise/main i386 Packages
Hit http://nova.clouds.archive.ubuntu.com precise/universe i386 Packages
Hit http://nova.clouds.archive.ubuntu.com precise/main TranslationIndex
Hit http://nova.clouds.archive.ubuntu.com precise/universe TranslationIndex
Get:15 http://nova.clouds.archive.ubuntu.com precise-updates/main Sources [412 kB]
Get:16 http://nova.clouds.archive.ubuntu.com precise-updates/universe Sources [93.9 kB]
Get:17 http://nova.clouds.archive.ubuntu.com precise-updates/main i386 Packages [692 kB]
Get:18 http://nova.clouds.archive.ubuntu.com precise-updates/universe i386 Packages [215 kB]
Get:19 http://nova.clouds.archive.ubuntu.com precise-updates/main TranslationIndex [3,564
B]
Get:20 http://nova.clouds.archive.ubuntu.com precise-updates/universe TranslationIndex [2,850
B]
Hit http://nova.clouds.archive.ubuntu.com precise/main Translation-en
Hit http://nova.clouds.archive.ubuntu.com precise/universe Translation-en
Get:21 http://nova.clouds.archive.ubuntu.com precise-updates/main Translation-en [304 kB]
Get:22 http://nova.clouds.archive.ubuntu.com precise-updates/universe Translation-en [125
kB]
Fetched 8,617 kB in 6s (1,308 kB/s)

So perhaps we can look if cloud-init is finished?
 
                
> Whirr installation fails to install java on ec2 machine 
> --------------------------------------------------------
>
>                 Key: WHIRR-674
>                 URL: https://issues.apache.org/jira/browse/WHIRR-674
>             Project: Whirr
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.8.1
>         Environment: ubuntu 12.04, 11.10
>            Reporter: ravi bhatt
>         Attachments: my_hadoop_cluster.whirr, whirr_output.txt
>
>
> Hi,
> I was trying to set up a hadoop cluster with 1 namenode and 2 datanodes. It was being
created on AWS and i tried installing on ubuntu 12.04 and 11.10. It fails to install java
on all the machine or at random times on some of the machines. 
> Since it cannot install java, it fails to install hadoop as well. Additionally it never
recognizes install_oracle_jdk6 even if i specify that in my properties file. 
> I have attached the output of the whirr command in whirr_output.txt. Also attached is
a whirr.log file thats generated when whirr runs and my properties file that i used to launch
a cluster.
> Thanks!
> Ravi
> PS: i have changed certain names and details in properties file which would not match
with that in the log files.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message