whirr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadas Gintautas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WHIRR-700) Cluster Compute Placement Groups don't work for hi1.4xlarge hardware
Date Tue, 05 Feb 2013 19:02:11 GMT

    [ https://issues.apache.org/jira/browse/WHIRR-700?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13571594#comment-13571594
] 

Vadas Gintautas commented on WHIRR-700:
---------------------------------------

The hardware specification for hi1.4xlarge is still incorrect in jclouds 1.5.7:

https://github.com/jclouds/jclouds/blob/jclouds-1.5.7/apis/ec2/src/main/java/org/jclouds/ec2/compute/domain/EC2HardwareBuilder.java#L355

https://github.com/jclouds/jclouds/blob/jclouds-1.5.7/providers/aws-ec2/src/main/java/org/jclouds/aws/ec2/compute/suppliers/AWSEC2HardwareSupplier.java#L70

I went ahead and checked out jclouds-1.5.7, made the changes to the above files, and compiled
whirr-0.8.1 against this.  The issue was not fixed: hi1.4xlarge instances are still not put
into placement groups.  I could not compile whirr-0.90-SNAPSHOT against jclouds 1.5.7 -- the
build failed at whirr-cassandra.

What troubles me is that, from what I can tell, the correct hi1.4xlarge hardware specification
meets all of the requirements for being a cluster compute instance and it should be put into
a placement group, and yet it doesn't happen.  See this comment:

https://issues.apache.org/jira/browse/WHIRR-63?focusedCommentId=13153742&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13153742
                
> Cluster Compute Placement Groups don't work for hi1.4xlarge hardware
> --------------------------------------------------------------------
>
>                 Key: WHIRR-700
>                 URL: https://issues.apache.org/jira/browse/WHIRR-700
>             Project: Whirr
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.8.1
>            Reporter: Vadas Gintautas
>
> Placement groups work for cc1.4xlarge and cc2.8xlarge instances but don't work for hi1.4xlarge
instances.  In an attempt to fix this I noticed that these were not correctly specified in
jclouds 1.5.1 (fixed in jclouds 1.6.0-SNAPSHOT). These are the differences between 1.5.1 and
1.6.0-SNAPSHOT. The virtualization type is now set to hvm:  https://github.com/jclouds/jclouds/blob/master/apis/ec2/src/main/java/org/jclouds/ec2/compute/domain/EC2HardwareBuilder.java#L359
> and the hi1.4xlarge are built with ccAMI support:  https://github.com/jclouds/jclouds/blob/master/providers/aws-ec2/src/main/java/org/jclouds/aws/ec2/compute/suppliers/AWSEC2HardwareSupplier.java#L71
> I cloned jclouds 1.5.1 and patched these differences locally.  I compiled whirr 0.8.1
against this, and while the virtualization type is now correct, placement groups are still
not created for hi1.4xlarge.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message