whirr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom White (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WHIRR-227) CDH and Hadoop integration tests are failing
Date Mon, 07 Feb 2011 05:27:30 GMT

    [ https://issues.apache.org/jira/browse/WHIRR-227?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12991265#comment-12991265
] 

Tom White commented on WHIRR-227:
---------------------------------

I've just uploaded the files so the 0.4.0-incubating-SNAPSHOT directory on S3 is in sync with
trunk. This was my fault, as I forgot to upload the files at the time of committing WHIRR-199
and WHIRR-183 (and then I was away for a few days without internet access, so it took a while
to fix!).

The policy should be that any committer is able to update the S3 bucket, but in practice I've
found it difficult to administer the permissions so that others are granted access (especially
to new directories). Given all this, I think we should move away from this model. I opened
WHIRR-225 to discuss this, so please have a look at the proposal there and add your comments.
The sooner we fix this, the better, IMO.

Again - sorry for the inconvenience!

> CDH and Hadoop integration tests are failing 
> ---------------------------------------------
>
>                 Key: WHIRR-227
>                 URL: https://issues.apache.org/jira/browse/WHIRR-227
>             Project: Whirr
>          Issue Type: Bug
>            Reporter: Andrei Savu
>            Priority: Critical
>             Fix For: 0.4.0
>
>
> I have tried multiple times (even using different internet connections and cloud providers)
to run the integration tests for cdh and hadoop and they always fail with the same error message:
> {code}
> -------------------------------------------------------------------------------
> Test set: org.apache.whirr.service.cdh.integration.CdhHadoopServiceTest
> -------------------------------------------------------------------------------
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 336.63 sec <<<
FAILURE!
> test(org.apache.whirr.service.cdh.integration.CdhHadoopServiceTest)  Time elapsed: 336.53
sec  <<< ERROR!
> java.io.IOException: Call to ec2-50-16-169-138.compute-1.amazonaws.com/50.16.169.138:8021
failed on local exception: java.net.SocketException: Malformed reply from SOCKS server
>   at org.apache.hadoop.ipc.Client.wrapException(Client.java:1089)
>   at org.apache.hadoop.ipc.Client.call(Client.java:1057)
>   at org.apache.hadoop.ipc.RPC$Invoker.invoke(RPC.java:226)
>   at org.apache.hadoop.mapred.$Proxy76.getProtocolVersion(Unknown Source)
>   at org.apache.hadoop.ipc.RPC.getProxy(RPC.java:369)
>   at org.apache.hadoop.mapred.JobClient.createRPCProxy(JobClient.java:486)
>   at org.apache.hadoop.mapred.JobClient.init(JobClient.java:471)
>   at org.apache.hadoop.mapred.JobClient.<init>(JobClient.java:456)
>   at org.apache.whirr.service.cdh.integration.CdhHadoopServiceTest.test(CdhHadoopServiceTest.java:87)
> {code}
> I believe this is somehow related to one of the recently committed patches.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message