whirr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom White (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WHIRR-188) [HBase] Rename options to newer non-whirr prefix style
Date Tue, 04 Jan 2011 18:08:47 GMT

    [ https://issues.apache.org/jira/browse/WHIRR-188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12977381#action_12977381

Tom White commented on WHIRR-188:

> Is it "hbase" for Apache HBase or "apache-hbase" since there might be also a "cdh-hbase"?
Or even "hbase" for shared and the others for specific services?

I think it should be "hbase" since we use "whirr.hbase-install-runurl" (or, better, "whirr.hbase.install-runurl")
to control which HBase to install.

> Should we use "whirr.hbase-configure-runurl" or "whirr.hbase.configure-runurl" or even
(see above) "whirr.apache-hbase.configure-runurl"?

"whirr.hbase.configure-runurl" is probably best. "whirr.hadoop-install-runurl" and "whirr.hadoop-configure-runurl"
don't conform to this, so perhaps we should deprecate these.

> [HBase] Rename options to newer non-whirr prefix style
> ------------------------------------------------------
>                 Key: WHIRR-188
>                 URL: https://issues.apache.org/jira/browse/WHIRR-188
>             Project: Whirr
>          Issue Type: Improvement
>          Components: service/hbase
>    Affects Versions: 0.3.0
>            Reporter: Lars George
>            Assignee: Lars George
>            Priority: Trivial
>             Fix For: 0.3.0
>         Attachments: WHIRR-188.patch
> I started this in WHIRR-25 with the Avro/Rest/Thrift servers. This cleans up the others

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message