velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafal Markut" <rafal.mar...@mediawave.de>
Subject Problem Encoding - Forms content
Date Tue, 18 Oct 2005 08:08:33 GMT
Hello,

I have following Problem. My system (Linux), Apache and Tomcat  (5.x) are 
set on UTF-8.
I use turbine 3.1 and velocity 1.3.1

I have in TurbineResources.properties:
services.VelocityService.input.encoding=UTF-8
services.VelocityService.output.encoding=UTF-8

In velocity file:
$data.setCharSet( "UTF-8" )
$page.setHttpEquiv("Content-Type", "text/html; charset=UTF-8")
and it's set on the WebPage correctly.

but ... when I press submit then in Action-Class:

public void doPerform( RunData data, Context context ) throws Exception
{
    data.getParameters().getCharacterEncoding() <- gives me US-ASCII
    data.getCharSet() <- gives me ISO-8859-1

but it should give me UTF-8 (not ISO).

Files on the file-system also are in UTF-8.

This application worked before as ISO-8859-1 on the server which was 
configured as ISO-8859-1.
But I changed all settings.

What can I do with it ?
I tried almost everything.

I would be very greateful for help.

with best regards,
Rafal 


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message