velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elton Hughes <ehug...@novaworks.org>
Subject Re: Odd Behavior - Solved!
Date Wed, 06 Apr 2005 20:39:49 GMT
Hi Mike,

Thank you for the suggestion and thank you for the time you put into 
this, but that did not work either.

But here is what did work.

I use a Mac running MacOS 10.3.8. I am using BBEdit as my text editor. 
It defaults to using Mac line endings. When I changed the line endings 
of the template to Unix line endings, it worked. Both lines appeared. I 
did not even touch the Velocity application.

So, it appears that the template requires either Unix or Windows line 
endings.

Thank you for your help.

Elton

On Apr 6, 2005, at 12:14 PM, Mike Curwen wrote:

> I've just copy and pasted your original code (with one modification to 
> get
> the resource loader path where I wanted it), and it "works for me".
>
> The one mod:
> Velocity.setProperty(Velocity.FILE_RESOURCE_LOADER_PATH, "c:\\tmpl\\");
> immediately before the call to Velocity.init();
>
> I get both firstName and lastName output, nothing clipped.


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message