velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "brian" <br...@westpole.com>
Subject RE: rendering velocity in websphere
Date Wed, 02 Jun 2004 21:52:51 GMT
I have read
http://jakarta.apache.org/velocity/tools/view/layoutservlet.html and
http://www.catb.org/~esr/faqs/smart-questions.html. I am trying to set
the layout using #set($layout="Login.vm") at the top of my screen. I get
a "Unable to find resource 'layout/Default.vm'" error when I try to
access the servlet from the browser. I even tried to change the default
layout value in the properties file. Please forgive me if I am
overlooking something that is obvious but I think that I am following
the documentation correctly.  Thanks,
      Brian 

-----Original Message-----
From: Nathan Bubna [mailto:nathan@esha.com] 
Sent: Wednesday, June 02, 2004 3:24 PM
To: Velocity Users List
Subject: Re: rendering velocity in websphere

brian said:
> I am having trouble showing my velocity templates in websphere. The
> first issue is in my web.xml file, I have tried to enter the first
page
> of the application which is Login.vm.  When I enter it as :
> /templates/app/screens/Login.vm , it does not include the layout which
> has the same name in the layouts directory.  When I enter it as
> /templates/app/layouts/Login.vm, it cannot find my images which are
> entered as <img src="$content.getURI("images/myBanner.gif")"> and it
> does not show the content for $screen_placeholder or $screen_content.
> Any help would be greatly appreciated. Thanks,

Please listen carefully.  if you are using the VelocityLayoutServlet (as
i
presume you still are from previous emails), then (for the third time)
you
should read

http://jakarta.apache.org/velocity/tools/view/layoutservlet.html

and do what it says.  If you have a problem, check the directions again
before
asking about it.  The document above describes how to set and use
layouts at
some length.  If you had read it and paid attention, you would know that
merely having a layout template of the same name as the screen template
is
*not* one of the ways to do layouts with the VelocityLayoutServlet.
that's
how Turbine works, Turbine does not use the VelocityLayoutServlet, nor
vice
versa.  They are two entirely separate things.

The same goes for the $content tool.  That is a *Turbine* tool, it is
not part
of VelocityTools and the VelocityLayoutServlet will *not* make it
available
for you in the context.

Oh, and once you have read

http://jakarta.apache.org/velocity/tools/view/layoutservlet.html

you should read

http://www.catb.org/~esr/faqs/smart-questions.html

Please do this as a favor to those of us patiently (well, not really
anymore)
answering your questions on this list.  It is fairly ridiculous that you
have
been pointed to

http://jakarta.apache.org/velocity/tools/view/layoutservlet.html

in two previous emails and are still asking questions that are clearly
and exp
licitly answered therein.  We write documentation so that we don't have
to
explain the same things over and over again to every newbie.

Thanks.

Nathan Bubna
nathan@esha.com


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: velocity-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: velocity-user-help@jakarta.apache.org


Mime
View raw message