velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Colson" <tcol...@cisco.com>
Subject RE: [Veltools] WebappLoader not loading
Date Fri, 03 May 2002 14:26:17 GMT
Gabe -

[Gabriel wrote]
> Your mail contains the output of velocity.log. Actually our 
> VelocityViewServlet implementation does not produce any 
> velocity.log. Instead the log output is redirected to the log 
> of the servlet container. 

I guarantee, it does produce the "velocity.log" file. This is running in
tomcat, but note that it is started up slightly differently than a
standalone server. It is run as a cmd line app, with a specific
classpath, and a specific server.xml config that sets the context path
to the project 'content' directory.

Incidentally(?) I've also noticed that sometimes AvalonKit is used, and
sometimes log4j. Log4J is always in the classpath, so I can only guess
that this is because of trying different versions of the VelocityXXX.jar
w/ and w/o dependancies.

And I've also noticed that while the init mesg. are sent to
velocity.log, the toolbox startup mesgs. appear to be going to stdout.


> Now, this leads me to the 
> conclusion that you modified/overwrote method initVelocity() 
> of VelocityViewServlet. 
Nope. The full text of the LayoutVelocityViewServlet was included - I
only overrode mergeTemplate(). That's all, truly.

> That is not a problem per se, but in 
> that same method is the code to load the WebAppLoader. Please 
> verify that this code is still there.
The code is still there. But I also stepped back and tried using just
the VelocityViewServlet and still had the same problem with webappLoader
not initializing.

> If the WebAppLoader is successfully loaded, it produces the 
> following log output:
Yeah...I've been trying to figure out what magic it takes to get that
back. The weird thing is that I did have it running, but I've tried
quite a few combinations without success.

I've tried using the jars from the velstruts/WEB-INF/lib as well as
nightly builds from both velocity and velocity-tools. I noticed that the
velocity-1.3XX.jar is different between the two.

Cheers,
Tim




--
To unsubscribe, e-mail:   <mailto:velocity-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-user-help@jakarta.apache.org>


Mime
View raw message