velocity-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Malcolm Davis" <malc...@nuearth.com>
Subject RE: benchmarking velocity
Date Thu, 31 Aug 2000 14:56:10 GMT
Benchmark?

That's an interesting concept.
I was taught to get it running first, 
worry about performance later.
Performance is one of those things 
you can always make better, look at the JVM's. :)

> -----Original Message-----
> From: Justin Wells [mailto:jread@semiotek.com]
> Sent: Thursday, August 31, 2000 5:10 AM
> To: velocity-user@jakarta.apache.org
> Subject: benchmarking velocity
> 
> 
> 
> I tried to benchmark velocity but I didn't get very far. 
> 
> First, I had to remove the #foreach directives from my 
> templates. Velocity reported some kind of parsing error
> so long as they remained in the template, complaining 
> that it still expected to see something when it reached
> the end of the file. I'm not sure why. The templates 
> contained fairly complex HTML so I figured there must
> be something confusing Velocity there.
> 
> Anyway, I removed the #foreach directives and continued
> on trying to benchmark. Velocity worked at this point, but
> it didn't work very well. 
> 
> I was able to view the page in my browser, but every time 
> I tried to hammer it with Apache Benchmark it got really 
> unhappy. A couple of times I got Out of Memory errors, and
> Apache Benchmark reports lots of bad connections. 
> 
> I think I must be using it wrong. Any ideas what happened?
> 
> Justin 
> 
> 

Mime
View raw message