velocity-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Rall <...@finemaltcoding.com>
Subject Re: installation problem...urgent
Date Thu, 02 May 2002 09:23:03 GMT
Do you know what version of the servlet API you're compiling against?

"Claude Brisson" <claude@savoirweb.com> writes:

> check you've got the last jsdk from sun (jsdk23.jar) : you're trying to compile with
an older version that doesn't have the method
> getInitParameter.
>
> CloD
> ----- Original Message -----
> From: "Srinivas" <srinuy2k@yahoo.com>
> To: <velocity-dev@jakarta.apache.org>
> Sent: lundi 29 avril 2002 15:06
> Subject: installation problem...urgent
>
>
>> hi,
>> i am trying to install velocity, downloaded from
>> nightly support. I did install ant successfully. but
>> while trying to run - ant jar-dep - it gives the
>> following error.
>>
>> compile:
>> java:313: cannot resolve[javac] symbol  :
>> method getInitParameter java.lang.String)
>> [javac] location: interface
>> javax.servlet.ServletContext
>> [javac]
>> propsFile = sc.getInitParameter(INIT_PROPS_KEY);
>>  [javac]                               ^
>>
>> C:\velocity\jakarta-velocity\bin\src\org\apache\velocity\servlet\VelocityServlet.java:316:
>> cannot resolve                    [javac] symbol  :
>> method getInitParameter  (java.lang.String)[javac]
>> location: interface javax.servlet.ServletContext
>>                  [javac]propsFile =
>> sc.getInitParameter(OLD_INIT_PROPS_KEY);
>>                     2 errors
>>
>>                       BUILD FAILED
>>                      Compile failed, messages should
>> have been provided.

--
To unsubscribe, e-mail:   <mailto:velocity-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:velocity-dev-help@jakarta.apache.org>


Mime
View raw message