velocity-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <ge...@optonline.net>
Subject Re: [GUMP] Test Failure - Velocity
Date Thu, 06 Sep 2001 22:11:44 GMT
On 9/6/01 7:12 AM, "Geir Magnusson Jr." <geirm@apache.org> wrote:

> ----------------------------------------------------
> This email is autogenerated from the output from:
> <http://jakarta.apache.org/builds/gump/2001-09-06/jakarta-velocity-test.html>
> ----------------------------------------------------
> 
> 
> test-texen:
>   [texen] /home/rubys/jakarta/jakarta-velocity/test/texen/results/report
>    [java] .
>    [java] Time: 0.101
>    [java] 
>    [java] OK (1 tests)
>    [java] 
> 
> test-texen-classpath:
> 
> BUILD FAILED
> 
> /home/rubys/jakarta/jakarta-velocity/build/testcases.xml:295:
> java.lang.NullPointerException
> 
> Total time: 57 seconds

I just tried this, a fresh build and test, and it works fine.  I wonder if
this is related to the "Singleton-challenged" nature of Ant 1.4?  Sam, I
assume that you are using that for Gump testing?

Can this be tried with Ant 1.3 to see if that is the case? If so, then the
solution might be to get Texen to use the separate runtime instance rather
than the singleton....

If not, then we emulate Sam's setup and debug...

geir

-- 
Geir Magnusson Jr.     geirm@optonline.net
System and Software Consulting
Developing for the web?  See http://jakarta.apache.org/velocity/
If you look up, there are no limits - Japanese Proverb


Mime
View raw message