velocity-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cbris...@apache.org
Subject svn commit: r1804358 - in /velocity/site/production/engine: 2.0/build.html devel/build.html
Date Mon, 07 Aug 2017 20:53:24 GMT
Author: cbrisson
Date: Mon Aug  7 20:53:23 2017
New Revision: 1804358

URL: http://svn.apache.org/viewvc?rev=1804358&view=rev
Log:
[site] Fix deprecations in build page (production)

Modified:
    velocity/site/production/engine/2.0/build.html
    velocity/site/production/engine/devel/build.html

Modified: velocity/site/production/engine/2.0/build.html
URL: http://svn.apache.org/viewvc/velocity/site/production/engine/2.0/build.html?rev=1804358&r1=1804357&r2=1804358&view=diff
==============================================================================
--- velocity/site/production/engine/2.0/build.html (original)
+++ velocity/site/production/engine/2.0/build.html Mon Aug  7 20:53:23 2017
@@ -224,13 +224,11 @@ h2:hover > .headerlink, h3:hover > .head
 }
 h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover
> .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink
{ visibility: visible }</style>
 <h2 id="installation">Installation<a class="headerlink" href="#installation" title="Permanent
link">&para;</a></h2>
-<p>Velocity runs on a variety of platforms that have installed the Java Virtual Machine.
The Java Development Kit version 1.6 is required for users who want to compile Velocity from
its source code.</p>
+<p>Velocity runs on a variety of platforms that have installed the Java Virtual Machine.
A Java Development Kit version 1.7+ is required to compile Velocity from its source code (as
it is to run it).</p>
 <p>Everything required to build Velocity comes with the distribution, which can be
obtained from <a href="http://svn.apache.org/repos/asf/velocity/engine/">Subversion</a>
or from the <a href="/download.cgi#engine">main distribution</a>. However, you
will need to install <a href="http://maven.apache.org/">Maven</a> to build the
Velocity sources.</p>
-<p><a href="http://maven.apache.org/">Maven</a> is also an Apache project.
To build Apache Velocity, you need at least Version 2.2.1 of Apache Maven.</p>
+<p><a href="http://maven.apache.org/">Maven</a> is also an Apache project.
To build Apache Velocity, you need at least Version 3.0.5 of Apache Maven.</p>
 <h2 id="required-tools">Required Tools<a class="headerlink" href="#required-tools"
title="Permanent link">&para;</a></h2>
-<p>To build Velocity we require <a href="http://maven.apache.org/">Maven</a>
version 2.2.1 or higher (Maven 3 can be used too) to perform the build process. We assume
that you have followed Maven's installation instructions and have it properly installed.</p>
-<p>Velocity requires JDK 1.6 or greater to compile.</p>
-<p>Finally, if you wish to modify Velocity's grammar you will need to a tool called
<a href="http://javacc.dev.java.net">JavaCC</a>. We recommend version 3.2 or greater.</p>
+<p>To build Velocity we require <a href="http://maven.apache.org/">Maven</a>
version 3.0.5 or higher to perform the build process. We assume that you have followed Maven's
installation instructions and have it properly installed.</p>
 <h2 id="building">Building<a class="headerlink" href="#building" title="Permanent
link">&para;</a></h2>
 <p>In each case below, it is assumed that you were successful in getting the distribution
from Subversion, and were successful in unpacking.  Also, it is assumed that you are starting
in the 'velocity' directory, the root of the distribution tree. All directory references will
be relative to 'velocity'.</p>
 <p>Change to the <strong>build</strong> directory (<code>cd build</code>).
Then, to build the jar file, simply type:</p>

Modified: velocity/site/production/engine/devel/build.html
URL: http://svn.apache.org/viewvc/velocity/site/production/engine/devel/build.html?rev=1804358&r1=1804357&r2=1804358&view=diff
==============================================================================
--- velocity/site/production/engine/devel/build.html (original)
+++ velocity/site/production/engine/devel/build.html Mon Aug  7 20:53:23 2017
@@ -224,13 +224,11 @@ h2:hover > .headerlink, h3:hover > .head
 }
 h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover
> .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink
{ visibility: visible }</style>
 <h2 id="installation">Installation<a class="headerlink" href="#installation" title="Permanent
link">&para;</a></h2>
-<p>Velocity runs on a variety of platforms that have installed the Java Virtual Machine.
The Java Development Kit version 1.6 is required for users who want to compile Velocity from
its source code.</p>
+<p>Velocity runs on a variety of platforms that have installed the Java Virtual Machine.
A Java Development Kit version 1.7+ is required to compile Velocity from its source code (as
it is to run it).</p>
 <p>Everything required to build Velocity comes with the distribution, which can be
obtained from <a href="http://svn.apache.org/repos/asf/velocity/engine/">Subversion</a>
or from the <a href="/download.cgi#engine">main distribution</a>. However, you
will need to install <a href="http://maven.apache.org/">Maven</a> to build the
Velocity sources.</p>
-<p><a href="http://maven.apache.org/">Maven</a> is also an Apache project.
To build Apache Velocity, you need at least Version 2.2.1 of Apache Maven.</p>
+<p><a href="http://maven.apache.org/">Maven</a> is also an Apache project.
To build Apache Velocity, you need at least Version 3.0.5 of Apache Maven.</p>
 <h2 id="required-tools">Required Tools<a class="headerlink" href="#required-tools"
title="Permanent link">&para;</a></h2>
-<p>To build Velocity we require <a href="http://maven.apache.org/">Maven</a>
version 2.2.1 or higher (Maven 3 can be used too) to perform the build process. We assume
that you have followed Maven's installation instructions and have it properly installed.</p>
-<p>Velocity requires JDK 1.6 or greater to compile.</p>
-<p>Finally, if you wish to modify Velocity's grammar you will need to a tool called
<a href="http://javacc.dev.java.net">JavaCC</a>. We recommend version 3.2 or greater.</p>
+<p>To build Velocity we require <a href="http://maven.apache.org/">Maven</a>
version 3.0.5 or higher to perform the build process. We assume that you have followed Maven's
installation instructions and have it properly installed.</p>
 <h2 id="building">Building<a class="headerlink" href="#building" title="Permanent
link">&para;</a></h2>
 <p>In each case below, it is assumed that you were successful in getting the distribution
from Subversion, and were successful in unpacking.  Also, it is assumed that you are starting
in the 'velocity' directory, the root of the distribution tree. All directory references will
be relative to 'velocity'.</p>
 <p>Change to the <strong>build</strong> directory (<code>cd build</code>).
Then, to build the jar file, simply type:</p>



Mime
View raw message