velocity-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cbris...@apache.org
Subject svn commit: r1804357 - in /velocity/site/cms/trunk/content/engine: 2.0/build.mdtext devel/build.mdtext
Date Mon, 07 Aug 2017 20:52:42 GMT
Author: cbrisson
Date: Mon Aug  7 20:52:42 2017
New Revision: 1804357

URL: http://svn.apache.org/viewvc?rev=1804357&view=rev
Log:
[site] Fix deprecations in build page

Modified:
    velocity/site/cms/trunk/content/engine/2.0/build.mdtext
    velocity/site/cms/trunk/content/engine/devel/build.mdtext

Modified: velocity/site/cms/trunk/content/engine/2.0/build.mdtext
URL: http://svn.apache.org/viewvc/velocity/site/cms/trunk/content/engine/2.0/build.mdtext?rev=1804357&r1=1804356&r2=1804357&view=diff
==============================================================================
--- velocity/site/cms/trunk/content/engine/2.0/build.mdtext (original)
+++ velocity/site/cms/trunk/content/engine/2.0/build.mdtext Mon Aug  7 20:52:42 2017
@@ -2,19 +2,15 @@ Title: Apache Velocity Engine - Building
 
 ## Installation
 
-Velocity runs on a variety of platforms that have installed the Java Virtual Machine. The
Java Development Kit version 1.6 is required for users who want to compile Velocity from its
source code.
+Velocity runs on a variety of platforms that have installed the Java Virtual Machine. A Java
Development Kit version 1.7+ is required to compile Velocity from its source code (as it is
to run it).
 
 Everything required to build Velocity comes with the distribution, which can be obtained
from [Subversion](http://svn.apache.org/repos/asf/velocity/engine/) or from the [main distribution](/download.cgi#engine).
However, you will need to install [Maven](http://maven.apache.org/) to build the Velocity
sources.
 
-[Maven](http://maven.apache.org/) is also an Apache project. To build Apache Velocity, you
need at least Version 2.2.1 of Apache Maven.
+[Maven](http://maven.apache.org/) is also an Apache project. To build Apache Velocity, you
need at least Version 3.0.5 of Apache Maven.
 
 ## Required Tools
 
-To build Velocity we require [Maven](http://maven.apache.org/) version 2.2.1 or higher (Maven
3 can be used too) to perform the build process. We assume that you have followed Maven's
installation instructions and have it properly installed.
-
-Velocity requires JDK 1.6 or greater to compile.
-
-Finally, if you wish to modify Velocity's grammar you will need to a tool called [JavaCC](http://javacc.dev.java.net).
We recommend version 3.2 or greater.
+To build Velocity we require [Maven](http://maven.apache.org/) version 3.0.5 or higher to
perform the build process. We assume that you have followed Maven's installation instructions
and have it properly installed.
 
 ## Building
 
@@ -30,4 +26,3 @@ Refer to Maven documentation for all pha
 
 If you find a problem, do not hesitate to ask the Velocity community
 via our [mail lists](/contact.html).
-

Modified: velocity/site/cms/trunk/content/engine/devel/build.mdtext
URL: http://svn.apache.org/viewvc/velocity/site/cms/trunk/content/engine/devel/build.mdtext?rev=1804357&r1=1804356&r2=1804357&view=diff
==============================================================================
--- velocity/site/cms/trunk/content/engine/devel/build.mdtext (original)
+++ velocity/site/cms/trunk/content/engine/devel/build.mdtext Mon Aug  7 20:52:42 2017
@@ -2,19 +2,15 @@ Title: Apache Velocity Engine - Building
 
 ## Installation
 
-Velocity runs on a variety of platforms that have installed the Java Virtual Machine. The
Java Development Kit version 1.6 is required for users who want to compile Velocity from its
source code.
+Velocity runs on a variety of platforms that have installed the Java Virtual Machine. A Java
Development Kit version 1.7+ is required to compile Velocity from its source code (as it is
to run it).
 
 Everything required to build Velocity comes with the distribution, which can be obtained
from [Subversion](http://svn.apache.org/repos/asf/velocity/engine/) or from the [main distribution](/download.cgi#engine).
However, you will need to install [Maven](http://maven.apache.org/) to build the Velocity
sources.
 
-[Maven](http://maven.apache.org/) is also an Apache project. To build Apache Velocity, you
need at least Version 2.2.1 of Apache Maven.
+[Maven](http://maven.apache.org/) is also an Apache project. To build Apache Velocity, you
need at least Version 3.0.5 of Apache Maven.
 
 ## Required Tools
 
-To build Velocity we require [Maven](http://maven.apache.org/) version 2.2.1 or higher (Maven
3 can be used too) to perform the build process. We assume that you have followed Maven's
installation instructions and have it properly installed.
-
-Velocity requires JDK 1.6 or greater to compile.
-
-Finally, if you wish to modify Velocity's grammar you will need to a tool called [JavaCC](http://javacc.dev.java.net).
We recommend version 3.2 or greater.
+To build Velocity we require [Maven](http://maven.apache.org/) version 3.0.5 or higher to
perform the build process. We assume that you have followed Maven's installation instructions
and have it properly installed.
 
 ## Building
 
@@ -30,4 +26,3 @@ Refer to Maven documentation for all pha
 
 If you find a problem, do not hesitate to ask the Velocity community
 via our [mail lists](/contact.html).
-



Mime
View raw message